Last Comment Bug 675627 - "error: Unrecognized directive ifndef" in nsIURIRefObject.idl
: "error: Unrecognized directive ifndef" in nsIURIRefObject.idl
Status: RESOLVED FIXED
fixed-in-bs
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla8
Assigned To: Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-01 08:03 PDT by Justin Lebar (not reading bugmail)
Modified: 2011-08-02 08:37 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (2.41 KB, patch)
2011-08-01 09:47 PDT, Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13)
benjamin: review+
Details | Diff | Review

Description Justin Lebar (not reading bugmail) 2011-08-01 08:03:30 PDT
I presume this is related to pyxpidl.  I see this on Windows and Linux.

error: Unrecognized directive ifndef, e:/builds/moz2_slave/try-w32/build/editor/idl/nsIURIRefObject.idl line 38:27
#ifndef nsIURIRefObject_h__
                           ^
error: Unrecognized directive define, e:/builds/moz2_slave/try-w32/build/editor/idl/nsIURIRefObject.idl line 39:27
#define nsIURIRefObject_h__
                           ^
error: Unrecognized directive endif, e:/builds/moz2_slave/try-w32/build/editor/idl/nsIURIRefObject.idl line 80:32
#endif /* nsIURIRefObject_h__ */
Comment 1 Benjamin Smedberg [:bsmedberg] 2011-08-01 08:23:56 PDT
This is related to somebody trying to use C++ preprocessor macros to an IDL file incorrectly. They should be removed, since it doesn't make any sense. Although I'm not sure what part of the recent pyxpidl stuff made this parsing more strict.
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2011-08-01 08:25:16 PDT
I'm a little concerned that the build isn't erroring out here ...
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2011-08-01 09:47:25 PDT
Created attachment 549832 [details] [diff] [review]
Patch

This makes the error fatal too.
Comment 4 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2011-08-01 11:38:00 PDT
http://hg.mozilla.org/projects/build-system/rev/94aa13f4a1a6
Comment 5 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2011-08-02 08:37:38 PDT
http://hg.mozilla.org/mozilla-central/rev/fa54a739294b

Note You need to log in before you can comment on or make changes to this bug.