Closed Bug 675642 Opened 9 years ago Closed 3 years ago

Embedded PDF's occasionally do not load inline, possible cache issue

Categories

(Core :: Plug-ins, defect)

All
Linux
defect
Not set
normal

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: tjgates, Unassigned)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.17) Gecko/20110518 Gentoo Firefox/3.6.17
Build ID: 20110518183715

Steps to reproduce:

Navigate to a web page with an embedded PDF with inline option selected for PDF file type handling.


Actual results:

Sometimes the page loads fine, other times (about 40% of time) a white page is displayed and firefox says 'done'. If I clear cache or refresh the page enough times the PDF will usually show up.


Expected results:

Firefox should be able to render the PDF inline every time without having to manipulate cache.

I have tried a new profile, upgrading/downgrading adobe reader and the problem still exists. This is happening on firefox version 3.6.16 and 5.x. and was NOT happening at version 3.6.12.
Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile

Please provide a public URL or reduced test case that exhibits this issue.

What version(s) of Adobe Reader have you used?
Yes this still happens in safe mode.

Creating new profiles doesn't help.

As for a public URL just do a google search for 'pdf' and click on any of the [pdf] tagged results. After a while they won't open.

Adobe Reader 9.4, 9.4.2

I've also noticed that sometimes embeded pdf's with a window size smaller than the max allowable won't even show a blank window, there will be nothing at all. ie 800x675
Does the issue occur with Adobe Reader x?
Yes. Using both 9.4.2 and 9.4.1. I know it is not adobe itself because back at ff 3.6.12 when it was working I used 9.4.1 and now that same version on the latest firefox does not solve the problem.
1) Adobe reader is at 9.4.5 IIRC and there is version 10. Please update to Adobe Reader X and see if the issue occurs

Please post the graphics section from about:support
If you can provide a link to these versions I will give it a shot. I cannot find anywhere on Adobe's website a version higher than 9.4.2 for Linux.
You're correct - 9.4.2 is the latest for linux.

Please post the graphics section from about:support
I have no "Graphics" section nor anything related to that in my about:support page, and I'm not sure where to find it.

I can say this happens on both Gentoo and Ubuntu (10.04 and 11.04) platforms, on different video cards: NVIDIA and VBOXVIDEO.
Forgot you were on 3.6 - there is no graphics section until FF4.

Is there a reason you haven't upgraded? Can you test the issue with the latest release and see if it occurs?
As I stated in my first post this is also happening on the latest release, the machine I was trying to pull the graphics info from at the time was a 3.x release.

What ever it is that's causing this happened between version 3.6.12 and 3.6.16.
(In reply to Tyler Gates from comment #10)
> As I stated in my first post this is also happening on the latest release,
> the machine I was trying to pull the graphics info from at the time was a
> 3.x release.
> 
> What ever it is that's causing this happened between version 3.6.12 and
> 3.6.16.

Please post the graphics section from about:support from the latest release
Graphics
      
Adapter DescriptionNVIDIA Corporation -- GeForce 7150M / nForce 630M/PCI/SSE2
Driver Version2.1.2 NVIDIA 173.14.30
WebGL RendererBlocked for your graphics driver version. Try updating your graphics driver to version NVIDIA 257.21 or newer.
GPU Accelerated Windows0/1. Blocked for your graphics driver version. Try updating your graphics driver to version NVIDIA 257.21 or newer.
Please update your graphics card driver and see if the issue persists
This is still happening with the lastest NVIDIA drivers (280.13).

Graphics
      
Adapter DescriptionNVIDIA Corporation -- GeForce 6200/PCI/SSE2Driver Version2.1.2 NVIDIA 280.13WebGL RendererNVIDIA Corporation -- GeForce 6200/PCI/SSE2 -- 2.1.2 NVIDIA 280.13GPU Accelerated Windows0/1
Can you attach a screenshot of what you are seeing?

Please attach the contents from about:support as a text attachment to this report
This time I googled for 'pdf', clicked on two pages worth of pdf's, then went back to the first pdf of the first page, tried to open it and got this.
If I refresh enough times it will appear.
Attached file About:Support
If you do a Reload (override cache) (https://support.mozilla.com/en-US/kb/Keyboard%20shortcuts) does it load immediately?
Hi Tim,
Hi Tim,
    Yes reloading does make it appear but it normally takes between one to five consecutive reloads before it appears -it rarely does it the first time.
Not exactly sure how to reproduce this issue, but encountered it myself a few times. Returning to pdf pages I once visited sometimes ends in displaying a blank page. This occurred pretty rarely and I haven't managed to reproduce it with a clean nightly profile in 10 minutes of pdf loading.
 
Mozilla/5.0 (X11; Linux x86_64; rv:9.0a1) Gecko/20110908 Firefox/9.0a1
Tyler -> Not just a reload, but a reload - override cache. Ctrl + F5 or Ctrl + Shift + R on Windows. Not sure on Linux. Does it work on the first try?
Tim,
   Yes Ctrl + F5 worked first time in two occurrences.
I've noticed blank pages tend to happen more often on the www.irs.gov website although it is not limited to them -if that helps troubleshooting any.
What is the status on this? This has cropped up even worse lately on magnushealth.com and it is seriously hindering productivity.
Ctrl + F5 on that website does not help, they have to restart firefox to get it to work again.
Version: 3.6 Branch → 6 Branch
seemingly relevant code changes from 3.6.14 to 3.6.15 causing pdf issues
A little more info:
Firefox 6 has been worse than 3.6 series and 7 seems to be worse than 6.

I believe I've tracked down the exact version firefox started exhibiting this issue: 3.6.15. The changelog for this version only says 'Fixed certain Java applets from not loading' and there appears to be no bug report associated with it. I've attached a patch which basically reverts this (and mostly back to version 3.6.14). Doing this against 3.6.15 fixes the problem. However, my problem now is that I can't identify what exactly in that code change is causing the pdfs to not load. Sifting through the latest firefox code has none of the same changes that was applied to 3.6.15 except for the 85 line code block  in nsNPAPIPlugin.cpp, so I'm stuck at the moment.

Tim: Is there any way we can track down the developer responsible for this change and see if he can identify what is going on?

Thanks,
   Tyler
3.6.15 was a chemspill release. I believe the relevant bug is Bug 629030
If you use the PDF reader instead of the PDF plugin (Options > Application), does it work for you?
Scoobidiver: Yes it does work launching from Adobe Reader itself rather than inline with firefox.
I've logged bug 697698 a month ago during a beta test. It's probably related to what's being reported here, but no work has been done there either. Seems this is specific for linux and has been going on for a while.
In case someone is expecting a bugfix for Fx3.6 here:
That will not happen, expect it is a serious security issue.
bug 697698 does look the same as this one except this happens when trying to load the pdf inline with firefox, I'm not sure if bug 697698 is referring to loading with Adobe Reader separately or inline with firefox or both.

I've tested firefox 7 as well as firefox nightly 11.0a1 and the issue is still there. My users say its happening with firefox 6 on Windows XP but I have not tried it myself.
Version: 6 Branch → 11 Branch
Duplicate of this bug: 697698
openSUSE 12.1, Adobe Reader 9.4.7, Mozilla/5.0 (X11; Linux i686; rv:13.0a1) Gecko/20120215 Firefox/13.0a1.

I have loaded several e-books from http://www.planetpdf.com/free_pdf_ebooks.asp (nice books by the way) plus i have used Google with the key word "pdf". Al pages handled by the Adobe browser plugin worked without issues.
Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120227 Firefox/13.0a1

I will confirm this now that I've duplicated bug 697698 to this one. This still occurs with the following steps:
1. Load any pdf file in Firefox (e.g. http://samplepdf.com/sample.pdf)
2. Close the pdf tab.
3. Wait for 30 seconds.
4. Load any pdf file once again (e.g. http://samplepdf.com/sample.pdf)

The pdf no longer loads after step 4, a black page is displayed instead.
Workaround: reloading the page will load the pdf correctly.

This is an old issue on Linux. Tracked up to Firefox 3.6.15 as specified in comment 26.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: x86 → All
Version: 11 Branch → Trunk
Component: File Handling → Plug-ins
Product: Firefox → Core
QA Contact: file.handling → plugins
Resolving old bugs which are likely not relevant any more, since NPAPI plugins are deprecated.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.