Closed Bug 675781 Opened 9 years ago Closed 8 years ago

First Last does not have a comma

Categories

(Thunderbird :: Address Book, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 10.0

People

(Reporter: rain1, Assigned: timeless)

Details

Attachments

(1 file, 2 obsolete files)

Attached patch patch (obsolete) — Splinter Review
(courtesy timeless)
Attachment #549949 - Flags: review?(mbanner)
Comment on attachment 549949 [details] [diff] [review]
patch

I'm not really happy with how "First Last" reads, but I agree that the comma shouldn't be there.  So, unasked-for-ui-r=me.  ;)

Later,
Blake.
Attachment #549949 - Flags: ui-review+
Comment on attachment 549949 [details] [diff] [review]
patch

Whilst we're not changing the context, as we seem to agree that without the comma makes sense, then we also want to make sure locales get updated. At 55 locales with the comma and 12 locales without, I think it would be worth updating the string id (and syncing the .accesskey) rather than filing lots of bugs.

I think we should also have an l10n comment explaining why we're not including the comma even though it is sort-of-natural to have it.
Attachment #549949 - Flags: review?(mbanner) → review-
Attached patch updated patch fixing comment (obsolete) — Splinter Review
Attachment #549949 - Attachment is obsolete: true
Attachment #559428 - Flags: review?(mbanner)
Did you miss adding a file to the diff?
yeah, oops.
Attachment #559428 - Attachment is obsolete: true
Attachment #559428 - Flags: review?(mbanner)
Attachment #562075 - Flags: review?(mbanner)
Attachment #562075 - Flags: review?(mbanner) → review+
https://hg.mozilla.org/comm-central/rev/f5a33f4b3f2b
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 10.0
You need to log in before you can comment on or make changes to this bug.