Last Comment Bug 675798 - about:memory shows compartment URLs for pages opened in Private Browsing mode
: about:memory shows compartment URLs for pages opened in Private Browsing mode
Status: RESOLVED DUPLICATE of bug 709326
:
Product: Toolkit
Classification: Components
Component: about:memory (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-01 16:25 PDT by Cameron McCormack (:heycam) (away Sep 28)
Modified: 2012-01-22 02:07 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Cameron McCormack (:heycam) (away Sep 28) 2011-08-01 16:25:53 PDT
STR:

1. Open a new Firefox session.
2. Start Private Browsing.
3. Go to a site you do not wish to be remembered, such as www.pigeonbasics.com.
4. Stop Private Browsing.
5. Open about:memory, and notice www.pigeonbasics.com is mentioned.
Comment 1 Nicholas Nethercote [:njn] 2011-08-01 22:36:42 PDT
Huh, interesting.  The JS memory reporters just iterate over the list of JS compartments held by the JS engine.  about:memory doesn't know anything about Private Browsing.

Presumably when Private Browsing exits a whole lot of stuff gets purged?
My hunch is that the JS compartment list should be purged as well...
Comment 2 Nicholas Nethercote [:njn] 2012-01-22 02:07:16 PST
Forward dup'ing this to bug 709326, because that one has more discussion.

*** This bug has been marked as a duplicate of bug 709326 ***

Note You need to log in before you can comment on or make changes to this bug.