Closed Bug 675805 Opened 11 years ago Closed 11 years ago

Turn off Tracemonkey repo

Categories

(Release Engineering :: General, defect, P3)

x86_64
Windows 7
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: dmandelin, Unassigned)

References

(Depends on 1 open bug)

Details

(Whiteboard: [automation])

Attachments

(3 files)

Close down the Tracemonkey repo. We'll use various project repos in JS in the future, but we won't need a team-specific branch.

But please don't do this before the dependent bugs are resolved.
Depends on: 675808
Priority: -- → P3
Whiteboard: [automation][blocked]
This isn't actually blocked on bug 675808 and can proceed any time, since it's been a couple of days shy of a month since anyone pushed anything to TraceMonkey, right?
The result of a |grep -rl tracemonkey .|
Also, |cd mozilla2; hg rm */tracemonkey| for the mozconfigs.
Do we need to clean up anything on buildapi or cruncher or graphs or ?
Attachment #556201 - Flags: review?(nrthomas)
Looks like graphs/server/analysis could use cleanup in general (still referencing Tp3, Tp4, Firefox 3.5). Not sure if that's still in use ?
Comment on attachment 556201 [details] [diff] [review]
kill tracemonkey, buildbot-configs

>diff --git a/talos-r3/config.py b/talos-r3/config.py
>diff --git a/talos-staging-pool/config.py b/talos-staging-pool/config.py

Wow, cleaning up dead code.
Attachment #556201 - Flags: review?(nrthomas) → review+
Attachment #556202 - Flags: review?(nrthomas) → review+
(In reply to Aki Sasaki [:aki] from comment #2)
> Do we need to clean up anything on buildapi or cruncher or graphs or ?

cruncher - main buildapi config
master running self-serve agent - agent config
  https://wiki.mozilla.org/ReleaseEngineering/BuildAPI#Adding_branches

nightly updates 
 - decide if we want to repatriate the ~350 nightly-tracemonkey users (requires custom snippet & mar) 
 - adjust http://mxr.mozilla.org/mozilla/source/webtools/aus/xml/inc/config-dist.php#115 

stage - remove firefox/nightly/latest-tracemonkey, mobile/nightly/latest-tracemonkey-*

IDK what the story is the the graphs schema, data usually survives.
There's probably some config for the talos regression watcher too, catlee knows where that is.
removed tracemonkey from regression watcher and buildapi
Flags: needs-reconfig?
Whiteboard: [automation][blocked] → [automation]
Attached patch aus patchSplinter Review
Attachment #556998 - Flags: review?(nrthomas)
Hm, that's removing not adjusting...
Attachment #556998 - Flags: review?(nrthomas)
David, do you need the ~350 Tracemonkey nightly users moved anywhere?
Or do you think they're likely tech-savvy enough to install a new nightly?
Duplicate of this bug: 683970
We are ready now...

David, I think comment 13 is a question from you.
Summary: Turn off Tracemonkey repo (when we are ready) → Turn off Tracemonkey repo
(In reply to Aki Sasaki [:aki] from comment #13)
> David, do you need the ~350 Tracemonkey nightly users moved anywhere?
> Or do you think they're likely tech-savvy enough to install a new nightly?

Please move them to normal Nightly.
This should be all done, except for migrating the Tracemonkey nightly users to the normal Nightly channel.
I'll get that. We have to change the update channel from nightly-tracemonkey to nightly, which can be done with the little mar file from bug 518508.
Had create a mar for mac, because has a 'Contents/MacOS/' pref on all file locations:
1, in an empty dir, create a file at 
  target/Contents/MacOS/defaults/pref/channel-prefs.js 
 which contains
//@line 2 "/builds/buildbot/moz2-slave/mozilla-central-macosx-nightly/build/browser/app/profile/channel-prefs.js"
pref("app.update.channel", "nightly");
2, get a checkout of a repo, I used 1.9.2, and modify tools/update-packaging/common.sh to remove the line
  -    ! -name "channel-prefs.js" \
from list_files()
3, create the mar
  <path_to_checkout>/tools/update-packaging/make_full_update.sh \
  update-channel-mac.mar target
4, grab the sha1sum and size of update-channel-mac.mar
5, push the mar up to the ftp server (/pub/mozilla.org/firefox/nightly/experimental/bug518508-update-channel/)
[To do this for non-mac just omit the Contents/MacOS from the path in step 1, and change the mar filename in 3. The comment in the js file is irrelevant.]

As ffxbld@aus2-staging, create and publish snippets. NB: appv/extv and buildID set so that the app doesn't reject the update:
cd /opt/aus2/incoming/2/Firefox/tracemonkey
for d in Darwin_x86_64-gcc3; do
  mkdir -p $d/20110729033600/en-US
  cat > $d/20110729033600/en-US/complete.txt << EOF
version=1
type=complete
url=http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/experimental/bug518508-update-channel/update-channel-mac.mar
hashFunction=SHA1
hashValue=9cb86620c328b41e11c1d624a50656b8c0e839bc
size=343
build=20110730000000
appv=8.0a1
extv=8.0a1
EOF
  mkdir -p $d/20110730000000/en-US
  touch $d/20110730000000/en-US/complete.txt
done

for d in Linux_x86_64-gcc3 Linux_x86-gcc3 WINNT_x86-msvc; do
  mkdir -p $d/20110729033600/en-US
  cat > $d/20110729033600/en-US/complete.txt << EOF
version=1
type=complete
url=http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/experimental/bug518508-update-channel/update-channel.mar
hashFunction=SHA1
hashValue=295dd63ff1e41ce0bc5322d19b932b0200c250f0
size=311
build=20110730000000
appv=8.0a1
extv=8.0a1
EOF
  mkdir -p $d/20110730000000/en-US
  touch $d/20110730000000/en-US/complete.txt
done
---

And adjust the cronjob so they don't get zapped, from
56    22  *  *  *  find /opt/aus2/incoming/2 -mindepth 4 -maxdepth 4 -mtime +6 -exec rm -rf {} \;
to
56  22  *  *  *  find /opt/aus2/incoming/2 -mindepth 4 -maxdepth 4 -mtime +6 ! -wholename '*tracemonkey*' -exec rm -rf {} \;
with an explanatory comment added.

Verified working with Linux32, Mac, and Win32 builds from [1], which is the last nightly build from tracemonkey. First upgrade swaps you from the nightly-tracemonkey channel to nightly, then the second updates you to the tip of Nightly (mozilla-central).

[1] http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/07/2011-07-29-03-36-00-tracemonkey/
We should leave config-dist.php alone so the above keeps working. That's all from the update side.
I think we're done here.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Flags: needs-reconfig?
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.