Fennec is confused by system zoom

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: glandium, Unassigned)

Tracking

Trunk
ARM
Android

Details

(Reporter)

Description

7 years ago
I don't know if this is an Asus-specific thing or if it comes with Honeycomb 3.2, but after the upgrade of my Asus Transformer to Honeycomb 3.2, there is a zoom icon in the notification area to change the zoom strategy for applications that "weren't designed for tablets". You can choose between "Stretch to fill screen" which is what you got by default before, and "zoom to fill screen", that basically makes the application look like what it would be on a mobile phone.

When choosing "zoom to fill screen", all I get is a black screen, and when going back to "stretch to fill screen", I get what I normally would get with "zoom to fill screen", and only killing and restarting fennec makes it look "normal" again.

Arguably, fennec should "simply" avoid this system from showing up (applications bundled with honeycomb don't make the zoom notification icon show up ; the kindle application doesn't either, for an example of an application that is not bundled with honeycomb)
More info here:
http://android-developers.blogspot.com/2011/07/new-mode-for-apps-on-large-screens.html

Since Fennec does not target tablets only (android:targetSdkVersion>=11), we get the screen compatibility mode. We can opt out of the mode by using a new "supports-screens" manifest setting.

<supports-screens android:xlargeScreens="true" />
(In reply to comment #1)

> <supports-screens android:xlargeScreens="true" />

This value was introduced in API level 9 :(
(In reply to comment #2)
> (In reply to comment #1)
> 
> > <supports-screens android:xlargeScreens="true" />
> 
> This value was introduced in API level 9 :(

that's fine, we can target level 9 and have 5 (or 7, 5 is kinda meaningless) as our minimum api level.

Not sure what sdk version is installed on our build slaves though. Aki?

Comment 4

7 years ago
android-sdk-r8.
Duplicate of this bug: 676134
Depends on: 676275
I have a Asus Transformer with Honeycomb 3.2, I can confirm this bug.
This is Fixed in Firefox 9 which should arrive in the Android market as Firefox Beta this week.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.