automatic storing IMAP emails (also sent) older than 30 days to save IMAP space

RESOLVED DUPLICATE of bug 675909

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 675909
7 years ago
7 years ago

People

(Reporter: wladi_missal, Unassigned)

Tracking

x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.122 Safari/534.30

Steps to reproduce:

I try using IMAP. My IMAP server offers me 300mb space, but I quite often exceed this space, so I'd like to have my inbox- and sent-folder archived automatically but maintaining the folder structure. 

I have a feature request respectively an idea I'd like to contribute.


Actual results:

Using filters to archive Inbox automatically works only for Inbox and only If I but the out of it into a Local Folder... thus breaking my familiar structure of having all mails in inbox in each of my 5 mail accounts.

If I start to archive everything in Local Folders it'll result in 5 times inbox (for each account) and 5 time ient (for each account). 
Besides it's not possible to archive emails in "Sent-Folders" automatically (by e.g. using filter rules).


Expected results:

Currently Thunderbird offers for IMAP folders the setting to delete mails of certain age to save server space. But I'd like to have a setting not to delete the mails, but to seperate the mails e.g. of the Sent-Folder visually from the younger ones on the server and to save them locally in the sent/inbox folder of the Imap account. But in a manner, that the server doesn't see them (deleted--> save space) but only thunderbird manages it to have them in its inbox-folder (slightly highlighted) only on the hard drive.

To explain it easier I have attached a PDF with my idea/concept of it. It looks quite easy to understand and it's absolutely intuitive.

I hope someone of you can give me some feedback and sees a way to implement it somehow somewhen..., as this would be an absolute unique thunderbird feature!

Yours sincerely

W. Missal

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 675909
You need to log in before you can comment on or make changes to this bug.