Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 676052 - gingerbread theme for android 2.3.5
: gingerbread theme for android 2.3.5
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 6
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
Depends on:
  Show dependency treegraph
Reported: 2011-08-02 12:24 PDT by microrffr
Modified: 2013-12-10 10:00 PST (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---

hack (I mean patch) (1.47 KB, patch)
2011-08-02 21:58 PDT, Mark Finkle (:mfinkle) (use needinfo?)
mbrubeck: review+
mark.finkle: approval‑mozilla‑aurora+
mark.finkle: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description microrffr 2011-08-02 12:24:19 PDT
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110622131247

Steps to reproduce:

Re: Bug 649820
After upgrading android from 2.3.4 -> 2.3.5, theme has reverted to classic.
See /mobile/themes/core/

Actual results:

classic theme

Expected results:

gingerbread theme
Comment 1 Aaron Train [:aaronmt] 2011-08-02 12:27:24 PDT

Needs an osversion=2.3.5, or would be better to change those to a 2.3.*
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-08-02 21:54:38 PDT
osversion=2.3.* does not do what you hope it would. '*' is seen as infinity, not as "match anything".

Bug 380401 tired to add a cleaner way to sandwich version tests between a lower (froyo) and a higher (honeycomb) range. We'll need the "range-based selection" mentioned in comment 12.

For now, adding a few dummy versions (*cough*hack*cough*) along with 2.3.5 would at least protect us against any new Gingerbread releases.
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-08-02 21:58:45 PDT
Created attachment 550299 [details] [diff] [review]
hack (I mean patch)

Patch adds some versions to the gingerbread theme. Sadly, we should consider moving this to aurora and beta.
Comment 4 Matt Brubeck (:mbrubeck) 2011-08-02 22:12:37 PDT
Comment on attachment 550299 [details] [diff] [review]
hack (I mean patch)

Told you so.*

*bug 653134 comment 15 :)
Comment 5 Tony Chung [:tchung] 2011-08-02 22:40:20 PDT
+% skin browser classic/1.0 %skin/gingerbread/ os=Android osversion=2.3 osversion=2.3.3 osversion=2.3.4 osversion=2.3.5 osversion=2.3.6 osversion=2.3.7

Eww.  so this will break if Gingerbread upgrades past 2.3.7?
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2011-08-02 22:51:56 PDT
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2011-08-02 22:52:52 PDT
(In reply to comment #5)

> Eww.  so this will break if Gingerbread upgrades past 2.3.7?

Yes, but bug 676183 will save us before then, I hope
Comment 8 Marco Bonardo [::mak] 2011-08-03 02:28:49 PDT
Comment 9 Matt Brubeck (:mbrubeck) 2011-08-03 08:08:46 PDT
Comment on attachment 550299 [details] [diff] [review]
hack (I mean patch)

Requesting approval-mozilla-aurora and approval-mozilla-beta.  This mobile-only change prevents new versions of Android from regressing Fennec's theme, by adding a few numbers to a hard-coded list of Android versions.

I know this is very late for Firefox 6, but this is an extremely low-risk change that fixes a very visible regression of a new feature in Firefox 6.
Comment 10 Aaron Train [:aaronmt] 2011-08-03 08:55:46 PDT, just want to confirm if what you are running is the Nexus S 4G model?
Comment 11 Mark Finkle (:mfinkle) (use needinfo?) 2011-08-03 09:24:34 PDT
Comment on attachment 550299 [details] [diff] [review]
hack (I mean patch)

Android only change that only affects the default theme used based on Android version number. Getting this on beta is important since the newer versions of Android are turning up in the field now.
Comment 12 Matt Brubeck (:mbrubeck) 2011-08-03 09:53:38 PDT
Landed on Beta (Firefox 6) and Aurora (Firefox 7):
Comment 13 microrffr 2011-08-03 11:43:43 PDT
:aaronmt, I'm using a Samsung Fascinate.
Comment 14 Aaron Train [:aaronmt] 2011-08-04 13:47:06 PDT
(In reply to comment #13)
> :aaronmt, I'm using a Samsung Fascinate.

Hi, you marked this bug as verified fixed, can you just confirm which build you see this fixed on now?
Comment 15 microrffr 2011-08-05 12:17:10 PDT
It's working on 2011/08/05 nightly right now.

Note You need to log in before you can comment on or make changes to this bug.