Closed Bug 676078 Opened 8 years ago Closed 8 years ago

Remove Mozmill (tests) related files from Firefox branches

Categories

(Testing Graveyard :: Mozmill, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
mozilla10

People

(Reporter: whimboo, Assigned: k0scist)

References

Details

(Whiteboard: [mozbase])

Attachments

(2 files)

As stated over on bug 653625 we want to remove Mozmill related files from mozilla-central and all the other Firefox branches. Here a statement from Clint:

> As Henrik well notes, those tests were from an earlier attempt at running
> mozmill in buildbot, and were we to try that again we'd go about it a
> different way, so I have no problem just hg removing them from m-c.  One
> caveat - run that on try though because they are also linked to make targets
> and you want to be sure you modify the make targets accordingly so they
> aren't looking for what doesn't exist.

Jeff, because you are the one who knows most about this landed code can you please take care of it's removal? I don't want to destroy anything because of the lack of knowledge in that area. Thanks.
Assignee: nobody → jhammel
Planning on doing this soon.  If there's anything we want to keep, or if anyone is using these tests, speak now or forever hold your peace.
See Also: → 516984
So this is more complicated than i expected.  The firebug tests rely on stuff in the mozmill directory:

http://mxr.mozilla.org/mozilla-central/source/testing/firebug/Makefile.in#42

I will try to figure out what to do here.
(In reply to Jeff Hammel [:jhammel] from comment #2)
> So this is more complicated than i expected.  The firebug tests rely on
> stuff in the mozmill directory:
> 
> http://mxr.mozilla.org/mozilla-central/source/testing/firebug/Makefile.in#42
> 
> I will try to figure out what to do here.

I think for the time being http://mxr.mozilla.org/mozilla-central/source/other-licenses/ is the place to put virtualenv and simplejson.  Ultimately, these should be upstreamed to e.g. mozilla-build. Right now they're ultimately hampering build+test turnaround for essentially static files
Whiteboard: [mozbase]
See Also: → 618924
see also https://bugzilla.mozilla.org/show_bug.cgi?id=685903 for firebug removal
See Also: → 685903
fix is here: http://k0s.org/mozilla/hg/mozilla-central-virtualenv/file/tip/bug-676078

Its too big to attach.
(In reply to Jeff Hammel [:jhammel] from comment #6)
> fix is here:
> http://k0s.org/mozilla/hg/mozilla-central-virtualenv/file/tip/bug-676078
> 
> Its too big to attach.

ctalbert: could you review please?
(In reply to Jeff Hammel [:jhammel] from comment #8)
> pushed to try:
> https://tbpl.mozilla.org/?tree=Try&usebuildbot=1&rev=ffd0e30a99a1

So there were a lot of infrastructure failures, but everything built fine and it did not look like there were any test failures caused by this
You also have to hg mv virtualenv and simplejson from testing/mozmill to other-licenses/
(In reply to Jeff Hammel [:jhammel] from comment #11)
> Created attachment 561518 [details] [diff] [review]
> the other parts of the patch

Generated as follows:

hg mv testing/mozmill/simplejson-2.1.1/ other-licenses/
hg mv testing/mozmill/virtualenv/ other-licenses/
hg rm testing/mozmill/
Note that if we merged this bug with bug 685903, the patch would end up being much simpler. Worth doing?
Attachment #561339 - Flags: review?(ctalbert)
Attachment #561518 - Flags: review?(ctalbert)
Attachment #561518 - Flags: review?(ctalbert) → review+
Comment on attachment 561339 [details] [diff] [review]
the useful parts of the patch

Looks good.  Let's run this on try server before checking in just to be safe. (Run with a full test battery on one OS just to ensure we don't pickle anything with the makefile changes)
Attachment #561339 - Flags: review?(ctalbert) → review+
This has been pushed to Try before and it passed there before.  Should I try again or is it good?
https://hg.mozilla.org/mozilla-central/rev/fa458dc8b04b
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla10
We may want to have buildbot run mozmill tests again at some point, but we can figure that out later. In any case, I'm glad to see unutilized code gone
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.