If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Edit approval page from admin dashboard now blank -- cannot approve edits

RESOLVED FIXED

Status

Websites Graveyard
getpersonas.com
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: dria, Assigned: MattN)

Tracking

Details

Attachments

(1 attachment)

It looks like today's update to getpersonas.com broke the ability for approvers to access (and therefore approve) edits.

STR:

1) Go here (with approver status): https://www.getpersonas.com/en-US/admin/dashboard.php
2) Click on the number beside "Personas Awaiting Edit Approval"

That's pretty much it.  The page should display the list of Personas awaiting edit approvals, but instead it's just blank.
I think this was caused by my recent check-in of r93018 for bug 652028.

Error Log output:

PHP Fatal error:  Cannot redeclare send_problem_email() (previously declared in /.../getpersonas.com/trunk/server/admin/editing.php:48) in /.../getpersonas.com/trunk/server/lib/review.php on line 94, referer: https://getpersonas.com.localhost/en-US/admin/dashboard.php

Not sure how this wasn't caught during testing or code review :(  This bug wasn't verified on stage before the push though.

I'll submit a patch ASAP.
Assignee: nobody → mmn100+bmo
Status: NEW → ASSIGNED
OS: Mac OS X → All
Hardware: x86 → All
Created attachment 550254 [details] [diff] [review]
v.1 Remove duplicate mail function and rename other

I didn't actually test the email sending since my dev. env. is not setup for that and I can't seem to get it working with email sending.  This gets rid of the fatal error though.
Attachment #550254 - Flags: review?(bsavage)
Do we have an ETA on when we can get this fixed?  The number of Personas in the edit queue is growing -- not quickly, but we're up to 85.
Comment on attachment 550254 [details] [diff] [review]
v.1 Remove duplicate mail function and rename other

This patch does not appear to break anything and should work as written. This approval is given with the caveat that I was unable to reproduce the issue described in this bug (which is probably also how it was not found when I tested the first patch). However, reviewing the patches together, this should solve the problem, but let's make sure we verify on staging.
Attachment #550254 - Flags: review?(bsavage) → review+
r93348

To Verify:
* that the edit approval page works
* edit accept email is sent
* edit reject email is sent
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(In reply to comment #5)
> To Verify: ...

FWIW, I verified all three items myself on stage and they worked as much as they can with bug 633290. The images didn't actually get switched on approval of an edit which I *think* is caused by that bug.  I did receive both types of emails though.
When can we expect this to be fixed on the live site?  The edit queue is in the hundreds now and this has been broken for over a week.
I filed bug 678083.  Adjust its severity accordingly.
This is now fixed on the live site!

Comment 10

6 years ago
Why did the fix take such a long time to be applied to the live site? Were there complications of some kind?
Component: getpersonas.com → getpersonas.com
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.