Open Bug 676183 Opened 10 years ago Updated 10 years ago

Allow chrome manifests to use range-selection for versions

Categories

(Core :: XPCOM, defect)

x86
Linux
defect
Not set
normal

Tracking

()

People

(Reporter: mfinkle, Unassigned)

Details

Manifests allow the use of osversion and appversion flags. There are situations where specifying a range of versions is desired.

I plan on using a scheme like:

osversion=2.3:2.4 
to mean "osversions between and including 2.3 and 2.4"
See bug 676052, comment 7 of why this is needed.
Colons are technically a valid character inside versions, so we might need a different operator, although I can't imagine anyone actually using a colon. Also per the previous discussion, we need to figure out whether the endpoints are inclusive. The most common use case will be >=N <N+1.
Component: Startup and Profile System → XPCOM
Product: Toolkit → Core
QA Contact: startup → xpcom
You need to log in before you can comment on or make changes to this bug.