Remember previous windows file associations

VERIFIED DUPLICATE of bug 64727

Status

SeaMonkey
Installer
--
major
VERIFIED DUPLICATE of bug 64727
17 years ago
13 years ago

People

(Reporter: Ingrid, Assigned: Sean Su)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20010201
BuildID:    20010201

If you install Mozilla or Netscape 6.x you can make it your default browser and
associate various file extensions with Mozilla.
However if you uninstall mozilla the file associations remain. However I think
that instead of just removing the associations Mozilla should do something
clever and remember what apps were associated with the file extensions so
uninstallation is painless.

Also the "Windows Integration" panel should do the same as deinstallation will
do, if you tell mozilla not to associate itself with a particular extension then
it should remember the previous application and restore that as the default.

Reproducible: Always
Steps to Reproduce:
1. Install mozilla
2. Set as default browser
3. Uninstall mozilla

Actual Results:  Mozilla is still associated with various filetypes .html, .gif,
.jpg, etc

Expected Results:  The file associations should return to those apps that they
were previously associated with but NOT assume a default application as the user
may, for example, have photoshop associated with gifs rather than IE, for
example


Unchecking a file association in the "Windows Integration" panel of preferences
should revert the file association to its previous state.

Marking severity as major because uninstalling an application shouldn't leave
your file associations in an unusable state.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 64727 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verified as duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.