Last Comment Bug 676275 - Update sdk on build slaves to api level 13
: Update sdk on build slaves to api level 13
Status: RESOLVED FIXED
[android][buildslaves][QA?]
:
Product: Release Engineering
Classification: Other
Component: Other (show other bugs)
: other
: ARM Android
: -- normal (vote)
: ---
Assigned To: Mike Taylor [:bear]
:
:
Mentors:
Depends on: 665716 677035 682171
Blocks: 603008 664149 669636 672661 675901
  Show dependency treegraph
 
Reported: 2011-08-03 09:25 PDT by Brad Lassey [:blassey] (use needinfo?)
Modified: 2013-08-12 21:54 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
9+


Attachments
sdk r12 rpm spec patch (2.13 KB, patch)
2011-08-03 14:05 PDT, Mike Taylor [:bear]
no flags Details | Diff | Splinter Review
sdk r12 rpm spec patch (1.34 KB, patch)
2011-08-04 10:29 PDT, Mike Taylor [:bear]
jhford: review+
Details | Diff | Splinter Review
puppet change for sdk r12 (1.37 KB, patch)
2011-08-04 10:42 PDT, Mike Taylor [:bear]
no flags Details | Diff | Splinter Review
puppet change for sdk r12 (1.37 KB, patch)
2011-08-04 11:31 PDT, Mike Taylor [:bear]
dustin: review+
bear: checked‑in+
Details | Diff | Splinter Review
sdk r12 rpm spec patch (1.29 KB, patch)
2011-08-04 14:51 PDT, Mike Taylor [:bear]
jhford: review+
bear: checked‑in+
Details | Diff | Splinter Review
sdk r13 rpm spec patch (1.16 KB, patch)
2011-08-08 12:28 PDT, Mike Taylor [:bear]
jhford: review+
bear: checked‑in+
Details | Diff | Splinter Review
puppet change for sdk r13 (2.66 KB, patch)
2011-08-08 12:29 PDT, Mike Taylor [:bear]
dustin: review-
Details | Diff | Splinter Review
puppet change for sdk r13 (2.67 KB, patch)
2011-08-08 12:48 PDT, Mike Taylor [:bear]
dustin: review+
bear: checked‑in+
Details | Diff | Splinter Review

Description Brad Lassey [:blassey] (use needinfo?) 2011-08-03 09:25:37 PDT
We're going to need to build against some APIs in honeycomb in the very near future and will need this SDK installed.
Comment 1 Mike Taylor [:bear] 2011-08-03 13:59:56 PDT
is api level 13 the same as Android SDK r12 ?
Comment 2 Mike Taylor [:bear] 2011-08-03 14:05:04 PDT
Created attachment 550498 [details] [diff] [review]
sdk r12 rpm spec patch
Comment 3 Alex Pakhotin (:alexp) 2011-08-03 14:14:31 PDT
The following line needs to be added to GeckoAppShell.java:
import android.text.ClipboardManager;

I'm not sure if this has to be a separate bug.
Comment 4 Brad Lassey [:blassey] (use needinfo?) 2011-08-03 14:17:57 PDT
(In reply to comment #3)
> The following line needs to be added to GeckoAppShell.java:
> import android.text.ClipboardManager;
> 
> I'm not sure if this has to be a separate bug.

yes, that's a seperate bug. This bug is just to get the sdk updated on the build slaves.
Comment 5 John Ford [:jhford] CET/CEST Berlin Time 2011-08-04 10:20:28 PDT
Comment on attachment 550498 [details] [diff] [review]
sdk r12 rpm spec patch

We fixed a couple issues with the Spec file above this morning.  Looking good
Comment 6 Mike Taylor [:bear] 2011-08-04 10:29:14 PDT
Created attachment 550740 [details] [diff] [review]
sdk r12 rpm spec patch

left http:// in Source0 figuring that we will be using mock soon enough
Comment 7 Mike Taylor [:bear] 2011-08-04 10:42:46 PDT
Created attachment 550744 [details] [diff] [review]
puppet change for sdk r12
Comment 8 John Ford [:jhford] CET/CEST Berlin Time 2011-08-04 11:03:18 PDT
Comment on attachment 550740 [details] [diff] [review]
sdk r12 rpm spec patch

Review of attachment 550740 [details] [diff] [review]:
-----------------------------------------------------------------

Cool,  r+ with the change in comment.

::: android-sdk/centos5-i686/android-sdk12.spec
@@ +10,5 @@
> +Group: Java
> +# This isn't the original source package but rather a Mozilla built tarball.
> +# The original source package requires downloading additional pieces from
> +# the Internet, which is difficult to do in RPM, and makes reproducability
> +# impossible.

Lets change this comment to the one that notes that we are going to be making modifications inside the spec file.
Comment 9 Mike Taylor [:bear] 2011-08-04 11:31:50 PDT
Created attachment 550761 [details] [diff] [review]
puppet change for sdk r12

fixed syntax error
Comment 10 Dustin J. Mitchell [:dustin] 2011-08-04 12:19:49 PDT
Doesn't that need a
            subscribe   => File["/tools/android-sdk"];
Comment 11 Mike Taylor [:bear] 2011-08-04 12:22:21 PDT
I'm moving away from having a symlink.  The symlink made since when we didn't have 4 "trains" running at the same time.

Now we just put the full dir name into the mozconfig. This also lets them have the dir for testing in try before it hits production mozconfigs
Comment 12 Mike Taylor [:bear] 2011-08-04 14:16:24 PDT
adding this note for future docs - to generate the tarball we use in puppet to install the sdk you have to do:

1. wget the sdk from google
2. tar xf 
3. on a linux box with a GUI, run ./tools/android
4. install the latest sdk using the android GUI
5. tar czf the sdk dir for use in the rpm
Comment 13 Mike Taylor [:bear] 2011-08-04 14:51:53 PDT
Created attachment 550836 [details] [diff] [review]
sdk r12 rpm spec patch

changed the Source0 value to be a local tarball since the SDK has to be processed after downloading it from Google
Comment 14 Mike Taylor [:bear] 2011-08-04 15:03:50 PDT
Comment on attachment 550836 [details] [diff] [review]
sdk r12 rpm spec patch

committed changeset 31:d7920d260d78
Comment 15 Mike Taylor [:bear] 2011-08-04 15:06:13 PDT
Comment on attachment 550761 [details] [diff] [review]
puppet change for sdk r12

committed changeset 427:b0299c73ab15
Comment 16 Mike Taylor [:bear] 2011-08-04 15:23:35 PDT
pushed to the production puppet servers
Comment 17 Mike Taylor [:bear] 2011-08-04 15:33:51 PDT
this is being rolled out to android builders now and will exist along side the current sdk

if you want to try the new one in Try then change your sdk path to be

/tools/android-sdk-r12
Comment 18 John Ford [:jhford] CET/CEST Berlin Time 2011-08-04 15:47:45 PDT
Comment on attachment 550836 [details] [diff] [review]
sdk r12 rpm spec patch

Review of attachment 550836 [details] [diff] [review]:
-----------------------------------------------------------------

::: android-sdk/centos5-i686/android-sdk12.spec
@@ +10,5 @@
> +Group: Java
> +# This isn't the original source package but rather a Mozilla built tarball.
> +# The original source package comes from Google and has to be un-tar'd and
> +# a GUI tool run to then install the proper SDK package
> +Source0: %{upstream_name}_%{upstream_ver}-linux_x86-releng.tar.bz2

sadfaces :(  if we gotta, we gotta
Comment 19 Mike Taylor [:bear] 2011-08-08 12:28:34 PDT
Created attachment 551532 [details] [diff] [review]
sdk r13 rpm spec patch

changed to sdk r13 and adjusted spec - this creates a new rpm because sdk-r12 has been deployed
Comment 20 Mike Taylor [:bear] 2011-08-08 12:29:36 PDT
Created attachment 551533 [details] [diff] [review]
puppet change for sdk r13

changed to installing r13 rpm and ensuring r12 is removed. also moved to using normal rpm package provider
Comment 21 Dustin J. Mitchell [:dustin] 2011-08-08 12:44:09 PDT
Comment on attachment 551533 [details] [diff] [review]
puppet change for sdk r13

+                            ensure    => latest,

should name the actual version, otherwise puppet will download the RPM on every invocation.
Comment 22 Mike Taylor [:bear] 2011-08-08 12:48:35 PDT
Created attachment 551540 [details] [diff] [review]
puppet change for sdk r13

good catch - updated to include version
Comment 23 Dustin J. Mitchell [:dustin] 2011-08-08 13:19:54 PDT
Comment on attachment 551540 [details] [diff] [review]
puppet change for sdk r13

I think you'll need quotes on the version number.  At any rate, they're probably advisable.  Good to commit with that change.
Comment 24 Mike Taylor [:bear] 2011-08-08 23:10:16 PDT
Comment on attachment 551540 [details] [diff] [review]
puppet change for sdk r13

committed changeset 428:be2164891049
Comment 25 Mike Taylor [:bear] 2011-08-08 23:18:06 PDT
Comment on attachment 551532 [details] [diff] [review]
sdk r13 rpm spec patch

committed changeset 32:c7e4e55b4579
Comment 26 Mike Taylor [:bear] 2011-08-09 08:15:51 PDT
puppet-masters have been updated and the android-sdk-r13 package is being installed.

The symlink for /tools/android-sdk will be updated to point to the new one after more than a simple "oh the build is green" test happens
Comment 27 Matt Brubeck (:mbrubeck) 2011-08-22 07:09:32 PDT
Have we built and run successfully with SDK 13 on Try?  Can we start pushing changes to the nightly mozconfigs?
Comment 28 Mark Finkle (:mfinkle) (use needinfo?) 2011-08-24 18:23:25 PDT
I pushed and built this on try:
http://tbpl.allizom.org/?usebuildbot=1&tree=Try&rev=00479e7d3440

It uses a mozconfig that bear provided to enable the SDK 13.

Builds are here:
https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/mfinkle@mozilla.com-00479e7d3440/

I installed and ran the opt APK on my Galaxy Tab (7") and it ran fine. I'll test on a few more devices and post results.
Comment 29 Mark Finkle (:mfinkle) (use needinfo?) 2011-08-24 18:29:18 PDT
Installed and ran fine on my Nexus One (gingerbread) and my Acer A500 tablet (honeycomb 3.1)

I think we should update the production mozconfigs to use SDK 13
Comment 30 Alex Pakhotin (:alexp) 2011-08-24 18:52:09 PDT
(In reply to Mark Finkle (:mfinkle) from comment #28)
> Builds are here:
> https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/mfinkle@mozilla.
> com-00479e7d3440/

The try build runs fine on T-Mobile myTouch 4G (Android 2.2.1), Nexus One (2.3.4), Galaxy Tab 10.1 (3.1).

I've just noticed the startup animation is not working as supposed, but I don't think it's related to the SDK.
Comment 31 Mark Finkle (:mfinkle) (use needinfo?) 2011-08-24 20:15:51 PDT
(In reply to Alex Pakhotin (:alexp) from comment #30)

> I've just noticed the startup animation is not working as supposed, but I
> don't think it's related to the SDK.

Different bug, already filed.

Note You need to log in before you can comment on or make changes to this bug.