Closed Bug 676318 Opened 9 years ago Closed 9 years ago

Glass shows through plugin areas

Categories

(Core :: Plug-ins, defect)

6 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 672058

People

(Reporter: netrolller.3d, Unassigned)

References

()

Details

(Keywords: relnote)

Attachments

(3 files)

In Firefox 6, some plugins have various degrees of display issues, usually relating to Windows Aero glass showing through black areas. In YouTube, this results in overlay texts getting corrupted. Another plugin that is badly affected is the Java online banking interface of the Hungarian "CIB Bank".

Steps to reproduce:
Load the URL (Java required). No need to login - the problem is already visible on the log-in screen.

Additional information: This is on a machine with a GeForce 7900 GTX graphics card, with 275.33 drivers (HW acceleration disabled).
An even worse example is http://www.dinofish.com/crosswords/010506/coelacross_01.html - not only is the background glass instead of black, but even the words "Down" and "Across" are written in glass!
Component: Extension Compatibility → Plug-ins
Product: Firefox → Core
QA Contact: extension.compatibility → plugins
* What version of Flash and Java are you using (from about:plugins)?
* What version of Windows are you using?
* Did you see this behavior in Firefox 4 and 5, or is it new in Firefox 6?
* Please paste the graphics information from about:support

I cannot reproduce the issue on the URLs you have provided (which are both Java), nor with youtube, which we test regularly.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Firefox: the latest 6.0 beta
Java: 6.0.260.3 (AKA U26)
Windows: 7, SP1

This is entirely new in Firefox 6. Firefox 5 behaved correctly.

About:support: (not copy/pasted directly, but reconstructed, as I have the Hungarian version of Firefox):
Adapter name: NVIDIA GeForce 7900 GTX
PCI vendor ID: 10de
PCI device ID: 0290
Video memory: 512
Driver name: nvd3dum
Driver version: 8.17.12.8019 (AKA 280.19 - also occurs with 275.33)
Driver date: 7-23-2011
Direct2D: false
DirectWrite: false (6.1.7601.17563) (Note: enabling DirectWrite in about:config causes all text in chrome and some in content to render as black rectangles)
ClearType parameters: Gamma: 2500 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 
WebGL renderer: Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)
GPU-accelerated windows: 1/1 Direct3D 9

I don't remember seeing this on a machine with a GeForce 9600M GT - perhaps it is specific to pre-DirectX 10 GPUs.
Also, Flash version is 10.3.181.26 (Shockwave Flash 10.3 r181). Flash is also affected, and so is the Windows Media Player plugin. This is in no way specific to Java.
Putting on the radar and adding a bunch of CCs. If this is a widespread breakage, we need to know about it right away because it might need a respin. Can we get QA to try to confirm and put together STR (and a regression range) while jim and benoit and josh figure out who wants to dissect the bug?
I cannot seem to reproduce this problem. Those who can should check if it happens without D3D9 layers. (disable hardware acceleration)
Comment 0 says hw acceleration is disabled. Would be good to verify this.
I haven't yet been able to reproduce in the lab with the Win 7 machines we have here - one of them is running with an NVIDIA Quadro NVS 295 adapter.
Quadro NVS 295 is a DirectX 10 GPGPU (per http://www.nvidia.com/object/product_quadro_nvs_295_us.html), with unified shaders. I think the trigger is a non-GP NVidia GPU(perhaps also ATi ones) with separate pixel and vertex shaders.
Attached image Ibank screenshot
Attached image Puzzle screenshot
WFM on Mozilla/5.0 (Windows NT 6.1; rv:6.0) Gecko/20100101 Firefox/6.0 (beta 5)

When I try to load the iBank url, I get a "security warning -> the certificate cannot be verified by a trusted source" but I think that is intended. After I press Yes button, the site loads fine. I have attached a screenshot with this and with the puzzle as well.
Gábor, would you be willing to use the regression finder tool at http://harthur.github.com/mozregression/ to find the nightly build in which this problem appeared? At this point I doubt that this issue is widespread enough to block the Firefox 6 release, but we should check input and other sources to make it's not a hidden-but-widespread issue.
@Vlad: What GPU do you have? (I suspect that you need an NVidia GPU with DirectX 9, but not 10, support for this to appear.)

@bsmedberg: I need to know which nightly build the current beta has branched from. (Also, how can I tell which beta I am running? The About screen currently reveals only the major and minor version, i.e. "6.0" - even on 5.0.1, it is only "5.0".)
According to https://wiki.mozilla.org/RapidRelease/Calendar you want to try the mozilla-central nightlies between 2011-04-12 and 2011-05-24
Bug traced back to the Strata Reloaded theme. Switching to Default fixed it.

Should this be INVALID?
(In reply to Gábor Stefanik from comment #17)
> Bug traced back to the Strata Reloaded theme. Switching to Default fixed it.
> 
> Should this be INVALID?

Thanks for the follow up. If you can, please contact the owner of the theme so they know of the problem.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
Marking VERIFIED INVALID based on previous comments.
Status: RESOLVED → VERIFIED
Keywords: relnote
Just got a response from the theme author - he is investigating this issue.
Do we think this could affect other themes as well? Should we do outreach?
(In reply to Christian Legnitto [:LegNeato] from comment #21)
> Do we think this could affect other themes as well? Should we do outreach?

Looks like it - see bug 680042.
Status: VERIFIED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 672058
You need to log in before you can comment on or make changes to this bug.