Last Comment Bug 676387 - XUL Elements with -moz-appearance shouldn't respond to clicks in their overflow
: XUL Elements with -moz-appearance shouldn't respond to clicks in their overflow
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All Mac OS X
: -- normal (vote)
: mozilla8
Assigned To: Markus Stange [:mstange]
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks: 672050
  Show dependency treegraph
 
Reported: 2011-08-03 14:48 PDT by Markus Stange [:mstange]
Modified: 2011-08-09 08:56 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (1.29 KB, patch)
2011-08-03 14:54 PDT, Markus Stange [:mstange]
roc: review+
Details | Diff | Splinter Review
with test, for checkin (3.38 KB, patch)
2011-08-04 08:26 PDT, Markus Stange [:mstange]
no flags Details | Diff | Splinter Review

Description Markus Stange [:mstange] 2011-08-03 14:48:30 PDT
It's possible to click a button's (possibly invisible) focus ring, but it shouldn't.
Comment 1 Markus Stange [:mstange] 2011-08-03 14:53:17 PDT
Looks like this doesn't happen in HTML.
Comment 2 Markus Stange [:mstange] 2011-08-03 14:54:08 PDT
Created attachment 550524 [details] [diff] [review]
v1
Comment 3 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-08-03 17:36:38 PDT
Comment on attachment 550524 [details] [diff] [review]
v1

Review of attachment 550524 [details] [diff] [review]:
-----------------------------------------------------------------

Seems like it should be fairly easy to write a testcase here
Comment 4 Markus Stange [:mstange] 2011-08-04 08:26:01 PDT
Created attachment 550697 [details] [diff] [review]
with test, for checkin
Comment 5 Markus Stange [:mstange] 2011-08-08 11:35:38 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/e45e7a591956

Note You need to log in before you can comment on or make changes to this bug.