Thank you note for contributions is not being sent

VERIFIED FIXED in 6.2.2

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: krupa, Assigned: Andy McKay)

Tracking

unspecified
6.2.2

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
steps to reproduce:
1. Pick an add-on which has Thank you email for contributions set up (https://addons.allizom.org/en-US/firefox/addon/bug-00000)
2. Make a contribution
3. Wait for the thank you note


actual behavior:
I never got the Thank you note.
Additional information: Krupa is using a different email address on PayPal and AMO.  I didn't realize we sent the email to the paypal address (which makes sense; oversight on my part), just need to change how we send emails if the email address isn't in the database.
(Reporter)

Updated

7 years ago
Blocks: 673583
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Additional information: Krupa is using a different email address on PayPal
> and AMO.  I didn't realize we sent the email to the paypal address (which
> makes sense; oversight on my part), just need to change how we send emails
> if the email address isn't in the database.

I tried using an account which had the same email id as my paypal account. I didn't get any emails even then.
Target Milestone: 6.1.8 → 6.1.9
Target Milestone: 6.1.9 → 6.2.0
Okay, I spent some time on this and I don't think it matters if the address is in the database or not.  However, I can't figure out how to actually play around with it locally, since it uses PayPal api calls.  Andy, any tips on doing paypal debugging locally?  I've spent an hour or so on it, and can't figure out the best way to do this.
(Assignee)

Comment 4

7 years ago
The email gets sent when Paypal sends in an IPN request. The tests for that are here and do all the fakery to pretend there's a Paypal request:

https://github.com/jbalogh/zamboni/blob/master/apps/amo/tests/test_views.py#L341

But it looks like those tests don't check that an email is being sent. So that should be added.

Once you are happy that's good, I would try sending a test IPN ping from Paypal sandbox over to preview (assuming your own zamboni instance is not accessible external). After logging into https://developer.paypal.com, hit Simulate Instant Payment Notification. I put a username and password in your root directory on khan.
Andy: Okay, I spent some time on this.  Locally, the problem seems to be this:
https://github.com/gkoberger/zamboni/blob/master/apps/amo/views.py#L252

(Pdb) urllib2.urlopen(settings.PAYPAL_CGI_URL, data, 20)
*** Exception: 
(Pdb) settings.PAYPAL_CGI_URL
'https://www.paypal.com/cgi-bin/webscr'
(Pdb) data
u'cmd=_notify-validate&'

So, the email isn't sending because it never gets past this line (at least locally).  Why are the tests trying to access an external URI?  Why don't they fail when they can't?  

The emails not sending are a side effect of a bigger problem -- the "c.mail_thanks()" code is never getting hit.  Any insights?  This paypal stuff is all greek to me, and I have no clue what's going on.
Target Milestone: 6.2.0 → 6.2.1
(Assignee)

Updated

7 years ago
Assignee: gkoberger → amckay
Target Milestone: 6.2.1 → 6.2.2
(Assignee)

Comment 6

7 years ago
http://github.com/jbalogh/zamboni/commit/009276
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

7 years ago
verified fixed. I just got the thank you note.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

7 years ago
Created attachment 557546 [details]
post-fix screenshot
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.