release_debug build fail to compile

VERIFIED FIXED in Q1 12 - Brannan

Status

Tamarin
Build Config
P2
normal
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: Sam, Assigned: pnkfelix)

Tracking

unspecified
Q1 12 - Brannan
x86_64
Windows 7
Bug Flags:
flashplayer-injection +
flashplayer-qrb +
flashplayer-bug +

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.122 Safari/534.30

Steps to reproduce:

Try to compile release_debug build for tamarin shell in Windows 7, Visual Studio 2008,


Actual results:

Compile error received:
..\..\VMPI\ThreadsWin.cpp(40) : error C2220: warning treated as error - no 'object' file generated
.\..\VMPI\ThreadsWin.cpp(40) : warning C4627: '#include "VMAssert.h"': skipped when looking for precompiled header use
        Add directive to 'VMPI.h' or rebuild precompiled header

Others (release, debug, debug_debugger) build successfully.


Expected results:

Should complete the build without error.
(Reporter)

Updated

7 years ago
OS: All → Windows 7
Hardware: All → x86_64
(Reporter)

Comment 1

7 years ago
changeset is 1a5728a5432d
Garnet reported a similar problem (though he did not say that it was solely on release_debu build).  Garnet said it was due to changeset 6452:a81addf0b027


  http://hg.mozilla.org/tamarin-redux/rev/a81addf0b027

In the log message for _that_ changeset, I noted: 

"""
I reordered the VMAssert and VMPI includes in ThreadsPosix.cpp and
ThreadsWin.cpp so that they match the ordering used in vmbase.h 
"""

Just to expand on this: my memory is that there are dependences *on* VMAssert.h in the recursive includes of VMPI.h for some platforms, and so VMAssert.h has to come first in some contexts.  (But maybe i am misremembering.)  Needs further investigation.
(Assignee)

Updated

7 years ago
Assignee: nobody → fklockii
Probably fixed by Lars in changeset:6452

changeset:   6539:a10bcde73326
tag:         tip
user:        Lars T Hansen <lhansen@adobe.com>
date:        Thu Aug 25 11:02:52 2011 +0200
summary:     Fix Visual Studio build breakage introduced by fklockii in rev 6452 (r=lhansen)


(sorry for letting this lie unfixed for two weeks; I have been meaning to go back and investigate the header file situation, but my plate has often been full of Serrano issues...)
(In reply to Felix S Klock II from comment #3) 
> changeset:   6539:a10bcde73326

http://hg.mozilla.org/tamarin-redux/rev/a10bcde73326

Updated

7 years ago
Flags: flashplayer-qrb+
Flags: flashplayer-injection+
Flags: flashplayer-bug+
Priority: -- → P2
Target Milestone: --- → Q1 12 - Brannan

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.