If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

UTest Bug ID: 199680 - Quiz - allows saving with less than 10 questions answered

VERIFIED FIXED

Status

Websites
webifyme.org
P1
major
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: webqa.utest, Assigned: brez)

Tracking

Firefox 5
x86
Mac OS X

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 550646 [details]
Quiz Gallery questions

Chrome 13.0.782.107
FF 5.0.2
Location = US
URL: https://webifyme-dev.allizom.org/en-US/quiz/

Steps taken:
1. Access home page at https://webifyme-dev.allizom.org/en-US
2. Click "Take the Quiz" link
3. Answer question 1
4. Click Skip up to question 11
5. Click Skip to End
6. Enter collage name, check box to appear in gallery, enter email and check box for T&C
7. Click Get Your Results

Expected:
Should not allow saving collage (according to test script line 18) without answering at least 10 questions.

Actual:
Collages are saved in gallery with less than 10 questions answered. (In attached screenshot, TJ Test 1 had 4 questions answered and TJ Test 2 had only 1 question answered.)
(Reporter)

Updated

6 years ago
Status: NEW → UNCONFIRMED
Ever confirmed: false

Comment 1

6 years ago
Confirmed and assigning to Brez.
Assignee: nobody → jbresnik
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
(Assignee)

Comment 2

6 years ago
Added a way to track the # of questions being answered:

https://github.com/mozilla/webifyme/commit/96c4a9aaa442e82b3797aeb0f9eaa8adc0d26a4b
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 3

6 years ago
I got a 500 while verifying this. however, i cannot reproduce it and the feature seems to be working fine.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.