Hang while displaying History menu after Sync import / Testpilot issues

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: ael, Unassigned)

Tracking

({hang})

7 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sync-places-hang?])

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:7.0a2) Gecko/20110804 Firefox/7.0a2
Build ID: 20110804042002

Steps to reproduce:

1) Loss of all history data (possibly related to the Testpilot New Tab study, since the timestamp on places.sqlite.corrupt matches activity in TestPilotErrorLog.log)

2) Created a clean profile and added it as a device to the existing sync account to retrieve history data from sync account

3) After completed sync, in this clean profile, trying to access the history menu fails. Clicking "History" in the menu, FF hangs for half a minute and never actually displays the menu. Accessing history via sidebar works. This persists after restart.

Some speculation from IRC #sync:
05:09:28 PM - rnewman: Possibly a bad record in the DB
05:09:45 PM - rnewman: and Places is not expecting it, and is dying on some operation that touches the DB during draw of the history menu

4) In the *original profile*, even after turning off testpilot studies via the toolbar button, and removing the testpilot add-on via the add-on manager, the new tab study is not completely removed. In particular, the new tab page remains modified, messages like "info: start jump prediction tracking" get written to the console, and the extensions subdir contains blanktab_multivaritate_test_testpilot@jetpack.
Please grab a snapshot of your original and fresh profiles. I'm sure they'll be needed for debugging, and it would be a shame to overwrite them.
Keywords: hang
Summary: History menu does not appear after sync import / Testpilot issues → Hang while displaying History menu after Sync import / Testpilot issues
Whiteboard: [sync-places-hang?]
(Reporter)

Comment 2

7 years ago
Well, the history loss has happened again - this time on restarting FF, without apparent add-on involvement. That puts Testpilot in the clear at least on that score, as it was no longer installed.
(Reporter)

Comment 3

7 years ago
Just installed Places Maintenance add-on (https://addons.mozilla.org/en-US/firefox/addon/places-maintenance/) which reports (on Integrity check) that

- The database is corrupt
> Reindex
- Unable to reindex database
> Integrity check
- The database is corrupt
- Unable to fix corruption, database will be replaced on next startup

Since FF apparently does this automatically every week or so, that probably explains the proximate cause of the history losses. It's not clear what damaged the database.

Anything one can do manually to rescue places.sqlite? Or must I live with the data loss?
heh, check disk and memory health, try to change security software/antivirus... So fare I have no cure for history loss (hope to have one soonish)
resolving since due to a corrupt database.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.