Bug 676586 (minotaur)

[meta] Implement a script debugger

RESOLVED FIXED

Status

()

Firefox
Developer Tools: Debugger
P3
normal
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: past, Assigned: past)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(blocking-kilimanjaro:+, firefox15 fixed)

Details

(Whiteboard: [sec-assigned:mgoodwin])

Implement an integrated JavaScript debugger for Firefox. This is a meta bug for keeping track of the various subtasks. See the feature page for details:

https://wiki.mozilla.org/DevTools/Features/Debugger
Assignee: nobody → past
Status: NEW → ASSIGNED
Depends on: 676590
Code repository for this work is currently at: http://hg.mozilla.org/users/dcamp_campd.org/remote-debug/
Depends on: 676592
Depends on: 676594
Depends on: 676602
Depends on: 676605
Depends on: 680044
Depends on: 680061
Depends on: 680062
Depends on: 685849
Depends on: 686684
Depends on: 687093
Depends on: 687095
Depends on: 688705
Depends on: 689875
Depends on: 690404
Depends on: 690419

Updated

6 years ago
Depends on: 690771
Depends on: 692405
Depends on: 692406
Depends on: 692409
Depends on: 693371
Depends on: 693996
Depends on: 694526
Depends on: 694538
Depends on: 694539
Depends on: 695279
Depends on: 695665
Depends on: 695728
Depends on: 697040
Depends on: 697761
Depends on: 697762
Depends on: 699419
Depends on: 700624
Depends on: 700639
Depends on: 702939
Depends on: 703718
Depends on: 706859
Depends on: 707987
Depends on: 709088
Depends on: 710213
Depends on: 710219
Depends on: 706506
Depends on: 710258
Component: Developer Tools → Developer Tools: Debugger
QA Contact: developer.tools → developer.tools.debugger
Depends on: 711164
Priority: -- → P3
Duplicate of this bug: 704041
Depends on: 722317
Depends on: 723047
Depends on: 723048
Depends on: 723059
Depends on: 723062
Depends on: 723069
Depends on: 723071
Depends on: 723563
Depends on: 724228
Depends on: 724229
Depends on: 724862
Depends on: 727429
Whiteboard: sec-review-needed

Updated

6 years ago
Keywords: sec-review-needed
Whiteboard: sec-review-needed
Previous security review notes (bug 697762):

https://wiki.mozilla.org/Security/Reviews/Firefox/RemoteDebug
Depends on: 729576
sec reviewer: mgoodwin
Whiteboard: [secr:mgoodwin]
Depends on: 731277
Depends on: 737464
Depends on: 740825
blocking-kilimanjaro: --- → ?
Alias: minotaur
Summary: Implement a script debugger → [meta] Implement a script debugger
Depends on: 746973
Depends on: 725733
Depends on: 732365
Depends on: 748749

Updated

5 years ago
Depends on: 732451
Depends on: 748927
Whiteboard: [secr:mgoodwin] → [secr-assigned:mgoodwin]
Depends on: 750736
Whiteboard: [secr-assigned:mgoodwin] → [sec-assigned:mgoodwin]

Updated

5 years ago
blocking-kilimanjaro: ? → +

Updated

5 years ago
Duplicate of this bug: 746864

Updated

5 years ago
Blocks: 746390
No longer depends on: 676602
No longer depends on: 694539
No longer depends on: 710213
Depends on: 753311
No longer depends on: 710258
Depends on: 753313
Depends on: 755346
Depends on: 755513
Depends on: 755661
No longer depends on: 755661
Depends on: 755385
SecReview Scheduled:
https://mail.mozilla.com/home/ckoenig@mozilla.com/Security%20Review.html?view=month&action=view&invId=110484-110483&pstat=AC&exInvId=110484-179672&useInstance=1&instStartTime=1337878800000&instDuration=3600000
Depends on: 756513
Depends on: 757128
No longer depends on: 727429
No longer depends on: 740825
Depends on: 758696
Depends on: 758683

Comment 7

5 years ago
Please change the flag from disabled to fixed if this is enabled for FF15.
status-firefox15: --- → disabled
status-firefox15: disabled → fixed
No longer depends on: 723071, 755513
Flags: sec-review?(mgoodwin)
this tracking bug is no longer needed.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
This has seen ongoing secreview including team reviews https://wiki.mozilla.org/Security/Reviews/Firefox/RemoteDebug and https://wiki.mozilla.org/Security/Reviews/Debugger - clearing secreview flag for housekeeping
Flags: sec-review?(mgoodwin) → sec-review+
Depends on: 939426
You need to log in before you can comment on or make changes to this bug.