Last Comment Bug 676605 - Refactor the script debugger to use the modified hook API
: Refactor the script debugger to use the modified hook API
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Panos Astithas [:past]
:
:
Mentors:
Depends on:
Blocks: minotaur
  Show dependency treegraph
 
Reported: 2011-08-04 11:30 PDT by Panos Astithas [:past]
Modified: 2011-08-17 11:55 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Panos Astithas [:past] 2011-08-04 11:30:58 PDT
The SpiderMonkey Debugger API has recently changed various hook method names, like newScript and setBreakpoint. We should merge the latest changes from jsdbg2 and refactor the code accordingly.
Comment 1 Panos Astithas [:past] 2011-08-05 22:50:19 PDT
Checkpointing my WIP due to imminent vacation. Merge done in:

https://hg.mozilla.org/users/pastithas_mozilla.com/remote-debug/rev/ae998a42606b

Initial refactoring and bustage fixing in my patch queue (fixmerge patch):

https://hg.mozilla.org/users/pastithas_mozilla.com/remote-debug-patches
Comment 2 Panos Astithas [:past] 2011-08-17 11:55:04 PDT
(In reply to Panos Astithas [:past] from comment #1)
> Checkpointing my WIP due to imminent vacation. Merge done in:
> 
> https://hg.mozilla.org/users/pastithas_mozilla.com/remote-debug/rev/
> ae998a42606b

This merge was thrown away, since by the time I got to work on this again, jsdbg2 had merged to m-c and retired. So I took the opportunity to do a single final merge:

https://hg.mozilla.org/users/dcamp_campd.org/remote-debug/rev/c84dd000af80

The necessary refactoring was done in:

https://hg.mozilla.org/users/dcamp_campd.org/remote-debug/rev/2e46bfe9c8eb

From now on we will be merging from m-c or fx-team and I will delete my personal repo mentioned above, soon, to avoid propagating redundant heads.

Note You need to log in before you can comment on or make changes to this bug.