The SpiderMonkey Debugger API has recently changed various hook method names, like newScript and setBreakpoint. We should merge the latest changes from jsdbg2 and refactor the code accordingly.
Checkpointing my WIP due to imminent vacation. Merge done in:
Initial refactoring and bustage fixing in my patch queue (fixmerge patch):
(In reply to Panos Astithas [:past] from comment #1)
> Checkpointing my WIP due to imminent vacation. Merge done in:
This merge was thrown away, since by the time I got to work on this again, jsdbg2 had merged to m-c and retired. So I took the opportunity to do a single final merge:
The necessary refactoring was done in:
From now on we will be merging from m-c or fx-team and I will delete my personal repo mentioned above, soon, to avoid propagating redundant heads.