Last Comment Bug 676713 - Places browser-chrome tests should use head.js:waitForClearHistory instead of defining their own impl
: Places browser-chrome tests should use head.js:waitForClearHistory instead of...
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
:
Mentors:
Depends on: 564900
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-04 15:45 PDT by Jared Wein [:jaws] (please needinfo? me)
Modified: 2011-08-18 12:40 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch for bug 676713 (6.47 KB, patch)
2011-08-08 10:27 PDT, Jared Wein [:jaws] (please needinfo? me)
mak77: review+
Details | Diff | Splinter Review

Description Jared Wein [:jaws] (please needinfo? me) 2011-08-04 15:45:42 PDT
As implemented by the patch for bug 564900, other mochitests in browser/components/places should use the |waitForClearHistory| function defined in head.js instead of defining their own version.

At the time of this filing, the following tests can be refactored:
browser_410196_paste_into_tags.js
browser_library_panel_leak.js
browser_forgetthissite_single.js
browser_sidebarpanels_click.js
browser_history_sidebar_search.js
Comment 1 Jared Wein [:jaws] (please needinfo? me) 2011-08-08 10:27:52 PDT
Created attachment 551495 [details] [diff] [review]
Patch for bug 676713

Some of the implementations of waitForClearHistory passed extra arguments to the callback function, but none of the callback functions referenced these arguments.

I ran all the tests locally and they still pass. Here is a link to the try server build: http://tbpl.mozilla.org/?tree=Try&rev=9fb5a88f71aa
Comment 2 Jared Wein [:jaws] (please needinfo? me) 2011-08-09 05:33:43 PDT
Comment on attachment 551495 [details] [diff] [review]
Patch for bug 676713

Requesting review from sdwilsh since Marco is on vacation.
Comment 3 Jared Wein [:jaws] (please needinfo? me) 2011-08-16 14:58:28 PDT
https://hg.mozilla.org/integration/fx-team/rev/a2b79dba6710
Comment 4 Rob Campbell [:rc] (:robcee) 2011-08-18 12:40:11 PDT
Comment on attachment 551495 [details] [diff] [review]
Patch for bug 676713

http://hg.mozilla.org/mozilla-central/rev/a2b79dba6710

Note You need to log in before you can comment on or make changes to this bug.