If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[SM 2.4.x] + Lightning 1.0b7 doesn't view the proper day and week-time in the calendar-view

RESOLVED WORKSFORME

Status

Calendar
Lightning: SeaMonkey Integration
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Mexx, Unassigned)

Tracking

({regression})

Lightning 1.1
regression

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.0; rv:5.0) Gecko/20110706 Firefox/5.0 SeaMonkey/2.2
Build ID: 20110706120824

Steps to reproduce:

Upgrade from SM 2.0.14 + lightning 1.0b1 to SM 2.2 + lightning 1.0b4 and after all update to lightning 1.0b5. My workday adjustments are default (08:00am to 5:00pm).


Actual results:

When I worked with SM 2.0.14 + lightning 1.0b1 the first start of the calendar (with week-view) works properly with 08:00am.

After updating to SM 2.2 + lightning 1.0b4 the first start of the calendar (with week-view) beginns with 00:00am instead of 08:00am (also after updating to lightning 1.0b5).

I adjusted this with using the scrollbar at the week-view to 08:00am but after a cpl. restart of the SeaMonkey the calendar-view will return to 00:00am. It doesn't depend on if I use the Windows- or Linux OS.

Addtional I found out that this strange behavoir doesn't exist with Thunderbird 5.0 + lightning 1.0b5 in any OS.
(Reporter)

Comment 1

6 years ago
I forgot to mentioned that this behavior doesn't depend on an existing or new profile.
Tentatively moving this bug to Calendar::Lightning:SeaMonkey_Integration.
Component: General → Lightning: SeaMonkey Integration
Product: SeaMonkey → Calendar
QA Contact: general → lightning-seamonkey
Version: SeaMonkey 2.2 Branch → Lightning 1.0b4

Comment 3

6 years ago
Confirmed with a fresh SM2.2 profile and direct installation of Lightning 1.0b5, so no upgrade path is need to reproduce.
Just open calendar once, switch to week-view, close MailNews, reopen MailNews and it's broken.

This used to work correctly in SM2.0.x with older Lightning afaik, therefore marking as regression.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows 2000 → All
Hardware: x86 → All

Comment 4

6 years ago
Tony, any relevant error messages in the Error Console?
(In reply to Philip Chee from comment #4)
> Tony, any relevant error messages in the Error Console?

I don't know, I don't experience this bug. My role here is only as triager.

Comment 6

6 years ago
Can't see any error except when closing the calendar-tab (don't know what causes this or if it's even calendar related at all, I am no developer):

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIXULTreeBuilder.getIndexOfResource]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://messenger/content/msgMail3PaneWindow.js :: EnsureFolderIndex :: line 1463"  data: no]

This is a new testing profile with no mail- or news-accounts.
(Reporter)

Updated

6 years ago
Version: Lightning 1.0b4 → Lightning 1.0b7
(Reporter)

Updated

6 years ago
Summary: [SM 2.2] + Lightning 1.0b5 doesn't view the proper day and week-time in the calendar-view → [SM 2.4.x] + Lightning 1.0b7 doesn't view the proper day and week-time in the calendar-view
(Reporter)

Comment 7

6 years ago
additional news:

Today the bug seems to be solved. Using:

Build-Identifikator: Mozilla/5.0 (Windows NT 5.0; rv:9.0.1) Gecko/20111221 Firefox/9.0.1 SeaMonkey/2.6.1

and

lightning 1.1

But I cannot say if the solution was the update from SM2.5 to SM2.6.1 or the update from lightning 1.0 to lightning 1.1

greets
-Markus
Version: Lightning 1.0b7 → Lightning 1.1
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.