"no attribute 'rfind'" error in Thunderbird 5.0 mozmill test

RESOLVED INVALID

Status

Thunderbird
General
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: YangLingling, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.16) Gecko/20110322 Fedora/3.6.16-1.fc14 Firefox/3.6.16
Build ID: 20110322223938

Steps to reproduce:

1) I got installed 
	*mozrunner-2.5.4(http://pypi.rhaptos.org/mozrunner/mozrunner-2.5.4.tar.gz)
	*jsbridge-2.4.3(http://pypi.rhaptos.org/jsbridge/jsbridge-2.4.3.tar.gz)
	*mozmill-1.5.3(http://pypi.rhaptos.org/mozmill/mozmill-1.5.3.tar.gz)

2)Download thunderbird-7.0a1.en-US.linux-i686.tests.zip from:
 http://ftp.mozilla.org/pub/mozilla.org/thunderbird/try-builds/Joachim.Herb@gmx.de-9d31da7237c6/try-linux/thunderbird-7.0a1.en-US.linux-i686.tests.zip

unzip it to thunderbird-7.0a1.en-US.linux-i686.tests

3)use "mozmill --version" to check the current version, it shows:"mozmill 1.5.3"

4)Change floder:
"# cd thunderbird-7.0a1.en-US.linux-i686.tests/mozmill "
(I following the instructions at  :
https://developer.mozilla.org/en/Thunderbird/Thunderbird_MozMill_Testing/Running_Thunderbird_MozMill_tests_from_packaged_tests)

5)Running all the tests
"# python runtestlist.py --binary=/usr/lib/thunderbird-5.0/thunderbird-bin --list=mozmilltests.list "



Actual results:


However, in the terminal it shows:

[root@oracle_desktop mozmill]# python runtestlist.py --binary=/usr/lib/thunderbird-5.0/thunderbird-bin --list=mozmilltests.list
INFO | (runtestlist.py) | Running directory: account
['python', 'runtest.py', '-t', 'account', '--binary', '/usr/lib/thunderbird-5.0/thunderbird-bin', '--symbols-path', '']
Traceback (most recent call last):
  File "runtest.py", line 441, in <module>
    ThunderTestCLI().run()
  File "runtest.py", line 310, in __init__
    TEST_NAME = os.path.basename(self.options.test)
  File "/usr/lib/python2.7/posixpath.py", line 111, in basename
    i = p.rfind('/') + 1
AttributeError: 'list' object has no attribute 'rfind'
##### MOZMILL-RICH-FAILURES-BEGIN #####
##### MOZMILL-RICH-FAILURES-END #####
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
INFO | (runtestlist.py) | account: 0 passed, 0 failed
INFO | (runtestlist.py) | Running directory: addrbook
['python', 'runtest.py', '-t', 'addrbook', '--binary', '/usr/lib/thunderbird-5.0/thunderbird-bin', '--symbols-path', '']
Traceback (most recent call last):
  File "runtest.py", line 441, in <module>
    ThunderTestCLI().run()
  File "runtest.py", line 310, in __init__
    TEST_NAME = os.path.basename(self.options.test)
  File "/usr/lib/python2.7/posixpath.py", line 111, in basename
    i = p.rfind('/') + 1
AttributeError: 'list' object has no attribute 'rfind'
##### MOZMILL-RICH-FAILURES-BEGIN #####
##### MOZMILL-RICH-FAILURES-END #####
......
......
......

##### MOZMILL-RICH-FAILURES-BEGIN #####
##### MOZMILL-RICH-FAILURES-END #####
TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during directory run
INFO | (runtestlist.py) | tabmail: 0 passed, 0 failed
INFO | (runtestlist.py) | Directories Run: 22, Passed: 0, Failed: 22


Expected results:

Actually ,when I change the version of mozmill to:
*mozrunner-2.5.4
*jsbridge-2.4.3
*mozmill-1.4.2b1(I change the maxVersion tags in the extesion/install.rdf file to make the test run for Thunderbird5.0)
It works quite Ok thunderbird 5.0 automation test.
So I guess the error might be caused by the new version of mozmill.
After updating the mozmill to the latest version ,it just still doesn;t work and raise the AttributeError: 'list' object has no attribute 'rfind'.

Any one can help to deal with the "AttributeError: 'list' object has no attribute 'rfind'"?
Thunderbird 5.0 doesn't support MozMill 1.5. We think we'll be able to start supporting MozMill 1.5 (and not require an external install) starting Thunderbird 8. Bug 656736 tracks its progress.

Since MozMill 1.4 works fine, this isn't a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.