News/Mail header list scrollbar starts in wrong place

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
18 years ago
7 years ago

People

(Reporter: twolf, Unassigned)

Tracking

({polish})

Trunk
mozilla1.0.1
polish

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20010130
BuildID:    20010130

When going from one newsgroup to another, Mozilla apparently doesn't reset the
scrollbar to the top - very annoying, because I typically
have messages sorted by reverse-date (newest message at top) and
constantly have to scroll back to the top whenever I change
newsgroups...

Reproducible: Always
Steps to Reproduce:
- Set the mail window to sort by reverse date.
- Go to a newsgroup with lots of messages.
- Scroll to and select a message that wasn't in the initial
view.
- Mark newsgroup read (prob.not necessary, but that's what I do :-)
- Go to another long newsgroup.

The scrollbar will not be at the start of the news window.

Actual Results:  Scrollbar is somewhere in the middle of the new newsgroup.

Expected Results:  When going to a newsgroup, I expect the scrollbar to start
at the top.
QA Contact: esther → stephend

Comment 1

18 years ago
Confirmed
Platform: PC
OS: Linux 2.2.16
Mozilla Build: 2001020512

Marking NEW. (and no you dont need to mark the newsgroup read to trigger the bug :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All
Hardware: PC → All

Updated

18 years ago
Keywords: polish
this might have been fixed with the new outliner widget.

if not, it should be easy to fix.

accepting.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9

Updated

18 years ago
Keywords: nsbeta1
Whiteboard: [nsbeta1+]
Target Milestone: mozilla0.9 → mozilla0.9.1
I just landed a fix that makes it so we scroll to the first new message when you
load a folder.  (unless you loaded the folder because of "next unread" cross
folder navigation)

if there are no new messages, I'll make it scroll to the top.

fix on the way...

fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
1.  When loading a folder with new messages, we scroll the pane to make them
visible.  2.  When loading a folder without new messages, we go straight to the
top of the folder pane.  
2001-04-09-04 Windows 2000.
2001-04-09-11 Mac OS 9.1
2001-04-09-10 Mandrake 7.2
Status: RESOLVED → VERIFIED

Comment 7

18 years ago
I'm using Build 2001091203 on Win2000 Pro, and this bug still exist, it is
always reproduceable, i.e. each time I open Mail Window, Message Headers list is
scrolled down a bit, so that the first message is not shown
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Updated

17 years ago
Blocks: 104166

Comment 8

17 years ago
Why scroll to the top?  Isn't the default (and most common) sort by increasing
date, with most recent (and therefor most interesting) messages at the bottom?
Perhaps this behavior should be sensitive to that. Even better would be to
persist the scroll state I had when I switched from the folder.  The current
behavior drives me nuts, since I lose my place in hundreds or thousands of
messages every time.  

I agree with scrolling to display any new messages.

Updated

17 years ago
Whiteboard: [nsbeta1+]
Target Milestone: mozilla0.9.1 → mozilla1.0.1

Comment 9

17 years ago
0.9.5 release build, Win2K SP2.  Very easy to recreate - if I
mark all newsgroups read, next to the next newsgroup.  All
newsgroups are sorted unread/thread, ascending dates.

If scrollbar appears (ie: enough messages), it will be partially down;
however, the correct message appears in the top of the window.  Scrollbar
works correctly from there downward, but if I go up, it flashes
and displays the correct first message.
Anything I can do to help ?

Comment 10

17 years ago
Trudelle: Bug 127663 cover automatically scrolling to the bottom when sorting by
date so that newest messages is at the bottom.  Want to plus it? :)

I don't like the idea of persisting the scroll state for each folder, because
someone who often scrolls within a folder will be in a different scroll position
each time he opens the folder.  I think that would be disorienting.

Comment 11

17 years ago
Jesse: No I don't want to plus that, even if I had the power.   I often scroll
within a folder too, and what you describe sounds exactly what I'm talking
about, every time I go back to a folder I'm in a different scroll position from
where I left it moments ago. (And yes, I know what you meant.)  If I wanted to
go to the top, I would just hit Home, but it is very difficult to get back to
where I was. BTW, there is no need to imagine what the persistent behavior would
be like, it is the way Messenger 4.x behaves when you have a selected message.  
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail
Status: REOPENED → NEW
Assignee: mail → nobody
QA Contact: stephend → message-display

Comment 12

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 13

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 14

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 15

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 16

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 17

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 18

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago9 years ago
Resolution: --- → EXPIRED
WFM.
Resolution: EXPIRED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.