Closed Bug 677109 Opened 9 years ago Closed 9 years ago

Preferences window cut-off due to checkbox image size constraint failure

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: aaronmt, Assigned: mfinkle)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Nightly (08/07)
Build: Mozilla/5.0 (Android; Linux armv7l; rv:8.0a1) Gecko/20110807 Firefox/8.0a1 Fennec/8.0a1
Device: Samsung Galaxy SII
OS: Android 2.3.3

Preferences are now cut-off.

Regression from bug 656329?
Severity: normal → major
Severity: major → normal
Attached patch patchSplinter Review
Something seems to have changed about the way XUL images use CSS to "size" themselves. I am guessing bug 585069, but I don't know for sure.

The patch uses "width" and "height" to set the size. We seem to use those everywhere else too. We probably used min-* and it worked, so we left it alone.

With the patch, the layout is back to normal.
Assignee: nobody → mark.finkle
Attachment #551375 - Flags: review?(mbrubeck)
Oh, only the gingerbread theme was affected.
No longer blocks: 656329
Attachment #551375 - Flags: review?(mbrubeck) → review+
Summary: Preferences window cut-off → Preferences window cut-off due to checkbox image size constraint failure
http://hg.mozilla.org/mozilla-central/rev/f414db34c70b
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Verified Fixed
Mozilla/5.0 (Android; Linux armv7l; rv:8.0a1) Gecko/20110808 Firefox/8.0a1 Fennec/8.0a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.