Firefox crash in Mac fonts

RESOLVED INCOMPLETE

Status

()

Core
Graphics
--
critical
RESOLVED INCOMPLETE
7 years ago
6 years ago

People

(Reporter: rcpereida, Unassigned)

Tracking

({crash})

5 Branch
x86
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 551355 [details]
bp-2cd151ba-a992-487e-b065-6270e2110807.txt

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/534.50 (KHTML, like Gecko) Version/5.1 Safari/534.50

Steps to reproduce:

Have used Firefox for years on a Macbook Pro and love it.  I recently had trouble with a virtual machine from VMWare.  I had to uninstalled vmware fusion and since than firefox on the mac side will not load.  It just sends crash reports. I have changed profiles,  I have tried to start in safe mode (no luck).  I have uninstalled and reinstalled and nothing seems to work.  Using the latest version of firefox for Mac running Snow leopard


Actual results:

 see above for attempts to solve problem.


Expected results:

Needs to start with all bookmarks and links intact.  If this this is the wrong place to present this problem please direct me to the correct location.

Many thanks

Comment 1

7 years ago
0 		@0x7fffffe00a00 	
1 	ATS 	ATS@0x24c46 	
2 	ATS 	ATS@0x18f7a 	
3 	ATS 	ATS@0x1313c 	
4 	ATS 	ATS@0x2c2c5 	
5 	libSystem.B.dylib 	libSystem.B.dylib@0x6153 	
6 	ATS 	ATS@0x54877 	
7 	XUL 	ATSFontEntry::GetFontTable 	gfx/thebes/gfxMacPlatformFontList.mm:372
8 	XUL 	MacOSFontEntry::ReadCMAP 	gfx/thebes/gfxMacPlatformFontList.mm:192
9 	XUL 	gfxPlatformFontList::RunLoader 	gfx/thebes/gfxFont.h:548
10 	XUL 	gfxFontInfoLoader::LoaderTimerCallback 	gfx/thebes/gfxFontUtils.h:924
11 	XUL 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:424
12 	XUL 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:520
13 	XUL 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:618
14 	XUL 	NS_ProcessPendingEvents_P 	nsThreadUtils.cpp:200
15 	XUL 	nsBaseAppShell::NativeEventCallback 	widget/src/xpwidgets/nsBaseAppShell.cpp:130
16 	XUL 	nsAppShell::ProcessGeckoEvents 	widget/src/cocoa/nsAppShell.mm:399
17 	CoreFoundation 	CoreFoundation@0x4e400 	
18 	CoreFoundation 	CoreFoundation@0x4c5f8
Severity: normal → critical
Crash Signature: [@ ATS@0x24c46 ]
Keywords: crash
This is a crash in a OS X system lib related to fonts.
Can you please check your fonts with fontbook ?
Component: General → Layout: Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
(Reporter)

Comment 3

7 years ago
Ran fontbook and found several fonts in duplicate which I corrected.  Firefox still doesn't start.  What else can I check in fontbook?
Do you have special fonts installed ?
I never worked on a mac and never used fontbook but it contains some kind of validity checking. Did you run that ?

Comment 5

6 years ago
rcpereida, ...

(In reply to Matthias Versen (Matti) from comment #4)
> Do you have special fonts installed ?
> I never worked on a mac and never used fontbook but it contains some kind of
> validity checking. Did you run that ?
Component: Layout: Text → Graphics
QA Contact: layout.fonts-and-text → thebes
Summary: Firefox crash report: c891a4c5-5c08-4e70-8657-c739b2110807 → Firefox crash in Mac fonts
Whiteboard: [closeme 2012-03-25]

Comment 6

6 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2012-03-25]
You need to log in before you can comment on or make changes to this bug.