HTML formating is stripped when there are only paragraphs.

RESOLVED DUPLICATE of bug 136502

Status

RESOLVED DUPLICATE of bug 136502
7 years ago
6 years ago

People

(Reporter: Usul, Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
1) So compose an email where the only formatting is <p> </p> and nothing else html wise (well appart from a few <br>).

2) send

This is send as plaintext even though send as hmlt + text is selected.

if you change one letter to be bold , it will be sent as html+text

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:8.0a1) Gecko/20110808 Thunderbird/8.0a1

Filling as UNCO. as this might be a duplicate and Joe probably knows better than I do.

Comment 1

7 years ago
Send format auto-detect works like this:
If the message can be down-converted to plaintext and that conversion is lossless then it will be converted to plaintext.
In the case of just <p tags this is true, there is no loss.
TB makes that decision for you. The only way to defeat it is to use Options>>Format and select a send mode there. (this must be done on every composition)
Bug 136502 wants a way to avoid the auto-detection by pref.
(Reporter)

Comment 2

7 years ago
(In reply to Joe Sabash from comment #1)
> Send format auto-detect works like this:

Thanks for the explanation Joe !!!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 136502
(In reply to Ludovic Hirlimann [:Usul] from comment #0)

Simplest/easiest workaround:
  <B></B>(or some other tags) in your HTML signature (<B>&nbsp;</B> required?)
You need to log in before you can comment on or make changes to this bug.