UTest Bug ID: 199719 - issue with Facebook link

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: webqa.utest, Assigned: brez)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 551447 [details]
Facebook issue

Platform type: PC
Current OS: Windows vista Business + SP2
IE8 8.0.6001.18943
Chrome
Location: USA
url of page: https://webifyme-dev.allizom.org/en-US/

Steps taken:
1. open application
2. click on Facebook link

Expected: 
facebook login page displays

Actual:
nothing occurred. Facebook link does not work

url of page: https://webifyme-dev.allizom.org/en-US/
(Reporter)

Updated

7 years ago
Status: NEW → UNCONFIRMED
Ever confirmed: false
Brez: In the code (https://github.com/mozilla/webifyme/blob/master/ff4/templates/shared/_share.html), can you change the src="http://www.facebook.... to https://? This will keep IE from barking at us due to the mixed protocols. Unlike twitter, Facebook has valid SSL certifications.
Assignee: nobody → jbresnik
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

7 years ago
Duplicate of this bug: 677736

Updated

7 years ago
Duplicate of this bug: 677737

Updated

7 years ago
Severity: normal → major

Comment 4

7 years ago
OK; this should be pretty easy.

Comment 5

7 years ago
This was related to bug 677480 - they used the same sharing module. See this commit:

https://github.com/mozilla/webifyme/commit/53258258e910145875984cd7ad0b1cb8921c1041

Chris: in addition, I have made the change you requested to the share button on the main page. I assume this will not cause IE to bark on an http:// page, yes? (I believe IE only barks when insecure content is on a https delivered page, and not the other way around).

Thats here, btw:

https://github.com/mozilla/webifyme/commit/dd7cd4f7e4acec588eacde958097ff9242e0c488

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.