Scrolling on my IBM ThinkPad with the middle mouse key is not working properly; when I get it to work in SeaMonkey, it won't in other programs

RESOLVED DUPLICATE of bug 673815

Status

RESOLVED DUPLICATE of bug 673815
7 years ago
7 years ago

People

(Reporter: jklansford, Unassigned)

Tracking

SeaMonkey 2.2 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20110706 Firefox/5.0 SeaMonkey/2.2
Build ID: 20110706120824

Steps to reproduce:

Dear Friends,
  
    I installed SeaMonkey 2.2.




Actual results:

    I am not very sophisticated about this stuff, so please bear with me.  I am hoping to get some additional help.  This problem surfaced when I installed SeaMonkey 2.2 -- I have never had it before.  Anyway, I installed 2.2.  I have an IBM ThinkPad with the center mouse key, that when held down, allows scrolling by moving the track point device in the middle of the keyboard.  The previous version of SeaMonkey allowed this scrolling.  Scrolling also worked in the Word Perfect menu and when you opened a file folder (e.g., "My Documents"), it would scroll in there, too.  I went into Sea Monkey preferences and, under "Appearance/Content", I selected "Use smooth scrolling".  I then went to Control Panel/Mouse and told the properties choice to use "Smooth".  That makes scrolling work in SeaMonkey (with a different little icon), but with that selected, scrolling does not work in Word Perfect or in the Windows folders.  When it works in Word Perfect or the Windows folders, it won't work in SeaMonkey.  Auto-select does not work either.

    Can you please help me?

Thank you.

Jamie 


Expected results:

Scrolling should have worked.
Please try the following:
1. Type about:config in the URL bar then hit Enter.
2. If told that this could void your warranty, answer that you'll be careful.
3. Type "autoscroll" (without the quotes) in the Filter box.
4. Everything should disappear except the line for the preference "general.autoscroll". If its value is "false" (which IIUC is the default), that's the cause of your problem. In that case you should double-click it to make it true. No need to restart SeaMonkey.

If the above didn't work for you, this bug might be a duplicate of either bug 605357 or bug 622410 depending on the driver (which you dindn't mention) of your thinkpad; in any case I'm not competent to decide so I'm bringing in someone who ought to be.
Hi Jamie.  As Tony mentioned, there have been a couple of issues surrounding Thinkpad scrolling recently.  One of these, bug 673815, has been resolved but not in time for SeaMonkey 2.2.

If you are able to, could you try this development version of SeaMonkey to see if it resolves your problem?  You can download it here:

http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-comm-central-trunk/seamonkey-2.5a1.en-US.win32.zip

Once you have it downloaded, extract it somewhere (your Desktop is fine), exit your SeaMonkey 2.2, then run the seamonkey.exe that you will find in the seamonkey folder that you extracted.  If it worked, great!-- the issue will be resolved in the next SeaMonkey release.  You can close that SeaMonkey, delete the extracted folder, and launch SeaMonkey 2.2 again.

If that did resolve the problem, and you want scrolling to work in SeaMonkey 2.2 in the meantime -- or if it didn't resolve the problem, but to try a workaround for it -- you can do the following:

  * Open SeaMonkey 2.2.
  * Type about:config in the URL bar and press Enter.
  * If it says "This might void your warranty", click on the "I'll be careful,
    I promise!" button.
  * Type "trackpoint" without the quotes in the Filter box.
  * There should be a single entry listed "ui.trackpoint_hack.enabled", and its
    value will probably be set to -1.  Double click that entry, type in 1 as
    its new value, and click OK.
  * Exit and the restart SeaMonkey 2.2.

Hopefully that should restore the TrackPoint scrolling behaviour.
(Reporter)

Comment 3

7 years ago
Dear Tony and Cam:

The general autoscroll line was already set to "true", so that did not go anywhere.  And, I was a little afraid to download the development version, so I went with the workaround.  The integer value had been set to -1 and I changed it to 1, as you suggested.  Then, I went into SeaMonkey preferences, unclicked "Use smooth scrolling" on the Appearance/Content page, went into control panel and switched the trackpoint back to "standard" and it works in SeaMonkey and in Word Perfect, Windows folders and also worked in Adobe!  You guys are geniuses and a BIG THANKS to you both.  Your directions were clear and easy to follow.
Thanks for the update, Jamie.  I think the Control Panel setting is what confused the other applications, and the "ui.trackpoint_hack.enabled" preference is what made SeaMonkey work with the original "standard" trackpoint mode.  Bug 673815 *probably* resolves this problem, so marking duplicate of that one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 673815
(Reporter)

Comment 5

7 years ago
Thank you again.  I really appreciate the fact that you folks with knowledge are out there to help the rest of us.  Very cool of you to spend your time helping us.
J

Updated

7 years ago
Duplicate of this bug: 677100
You need to log in before you can comment on or make changes to this bug.