Last Comment Bug 677433 - Run jit-tests in valgrind automatically if available, in |make check|
: Run jit-tests in valgrind automatically if available, in |make check|
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla8
Assigned To: general
:
Mentors:
Depends on:
Blocks: 675283
  Show dependency treegraph
 
Reported: 2011-08-08 17:42 PDT by Paul Biggar
Modified: 2011-08-10 08:34 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
unconditionally call with --valgrind (1.33 KB, patch)
2011-08-08 17:42 PDT, Paul Biggar
n.nethercote: review+
Details | Diff | Splinter Review

Description Paul Biggar 2011-08-08 17:42:19 PDT
Created attachment 551641 [details] [diff] [review]
unconditionally call with --valgrind

In bug 675283, we want to reenable |make check-valgrind| on buildbot. |make check-valgrind| runs the entire jit-test suite, in the same way as |make check|, with the only difference being that 3 test cases are run in valgrind instead.


Since |make check| is for buildbot anyway, we should just always run this with valgrind.


It would nice to make jit-test always run with valgrind, but it adds 30s to a build that only takes 1m otherwise, so this probably isn't worth it.
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2011-08-09 01:47:03 PDT
So wouldn't this need a build with --enable-valgrind?
Comment 2 Paul Biggar 2011-08-09 15:24:19 PDT
I think the major feature of --enable-valgrind is turning off valgrind, but |make check| runs on the shell which doesn't use valgrind.

Note You need to log in before you can comment on or make changes to this bug.