Note: There are a few cases of duplicates in user autocompletion which are being worked on.

double-clicking on a word and extending the selection doesn't include the first word

UNCONFIRMED
Unassigned

Status

()

Core
Selection
UNCONFIRMED
6 years ago
4 years ago

People

(Reporter: Vincent Lefevre, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0 Iceweasel/5.0
Build ID: 20110730084237

Steps to reproduce:

I double-clicked on a word (holding the mouse button) and extended the selection to the right by moving the mouse pointer and releasing the mouse button.


Actual results:

The first word was not always selected. The last time this problem occurred, the space between the first and the second word was selected together the remaining of the selection rightwards (something that is particularly difficult to reproduce, as a selection made from a double-click normally starts on a word boundary).

I don't know how to reproduce this problem, but it occurred several times today. IIRC, it has never occurred with Firefox 3.x.


Expected results:

The first word should have been selected.
Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110815 Firefox/8.0a1

Works for me on the latest nightly.

Could you give a repro. percentage of the issue? How many times does it reproduce in to say-about 10-tries?

Did it happen more often on specific websites?

Does the issue still occur if you start Firefox in Safe Mode?
http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile?
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
(Reporter)

Comment 2

6 years ago
I'm closing the bug as I can no longer reproduce it. I don't know whether something particular occurred on the system this day or there is something particular to do to reproduce it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

6 years ago
Reopening as I've found a way to reproduce it with Iceweasel 10.0.2 (Debian), though not 100% of the time. For instance, on this page, in the bug description:
1. Double-click on "User" (in the line "User Agent: Mozilla/5.0 ..."), without releasing the mouse button.
2. Move the mouse pointer upward to "Vincent".
3. Move the mouse pointer downward back to "User". Most often, this has the effect to deselect "User", which is wrong!
4. Move the mouse pointer to the right: this selects words, and "User" is still unselected.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 4

4 years ago
With Iceweasel 19.0.2 (Debian), I can reproduce the bug 100% of the time.
You need to log in before you can comment on or make changes to this bug.