Last Comment Bug 677464 - (update-notes) Update "NOTES" sections in MathML demo pages
(update-notes)
: Update "NOTES" sections in MathML demo pages
Status: RESOLVED FIXED
: helpwanted
Product: Core
Classification: Components
Component: MathML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Frédéric Wang (:fredw)
:
Mentors:
http://www.mozilla.org/projects/mathm...
Depends on:
Blocks: mathml-demos
  Show dependency treegraph
 
Reported: 2011-08-09 00:06 PDT by Frédéric Wang (:fredw)
Modified: 2011-10-13 17:38 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch V1 (2.36 KB, patch)
2011-09-25 12:11 PDT, Frédéric Wang (:fredw)
no flags Details | Diff | Splinter Review
Patch V2 (2.59 KB, patch)
2011-10-13 05:16 PDT, Frédéric Wang (:fredw)
karlt: feedback+
Details | Diff | Splinter Review
Patch V3 (21.49 KB, patch)
2011-10-13 14:49 PDT, Frédéric Wang (:fredw)
karlt: review+
Details | Diff | Splinter Review
Patch V3 - part 2 (5.60 KB, patch)
2011-10-13 15:15 PDT, Frédéric Wang (:fredw)
no flags Details | Diff | Splinter Review
Patch V3 - part 2 (8.59 KB, patch)
2011-10-13 15:33 PDT, Frédéric Wang (:fredw)
karlt: review+
Details | Diff | Splinter Review

Description Frédéric Wang (:fredw) 2011-08-09 00:06:55 PDT
The menu description should all use <span class="menu"> and be updated to reflect current menu item names. Actually, the menu is no longer displayed by default in Firefox, so we may want to find another description, via keyboard shortcut for example.

The links to the bug tracker should be removed now bug 120198 is closed.
Comment 1 Frédéric Wang (:fredw) 2011-09-25 12:11:11 PDT
Created attachment 562316 [details] [diff] [review]
Patch V1

Proposal of changes for the notes in the Torture Test (the same should be made to other pages).

Probably we can remove the viewmath.js/viewsource.css feature, since the view source command is already available in the contextual menu.
Comment 2 Karl Tomlinson (:karlt) 2011-10-10 21:26:04 PDT
Comment on attachment 562316 [details] [diff] [review]
Patch V1

class="menu", removal of the link to bug 120198, and "→" are all good, thanks.

(In reply to Frédéric Wang (:fred) from comment #0)
> The menu description should all use <span class="menu"> and be updated to
> reflect current menu item names.

The distinction between Edit→Preferences and Tools→Options is
platform-specific.
http://hg.mozilla.org/mozilla-central/annotate/70e4de45a0d0/browser/locales/en-US/chrome/browser/browser.dtd#l506

> Actually, the menu is no longer displayed by default in Firefox, so we may
> want to find another description, via keyboard shortcut for example.

The menu is still displayed on Linux.

Is it displayed on Mac?  (I would have guessed it is on Mac because I can't
imagine using Mac's menubar for anything else.)

On the platform that most of our users have, the menubar is not displayed by
default.  I don't really understand the UI there, so it's unclear what's best.

However, I'd prefer to stick with menus because the Alt+V/E keyboard
shortcuts are localization-specific (and platform-specific too perhaps) and
really based on the menubar entries anyway.  The menu names are also
localization-specific, but it is easier to guess the translation of a menu
name than the translation of a keyboard shortcut.

Firefox→Options→Menubar will enable the menu bar on systems with only the Firefox menu, so perhaps that can be mentioned.
Comment 3 Karl Tomlinson (:karlt) 2011-10-10 21:28:00 PDT
(In reply to Frédéric Wang [offline] from comment #1)
> Probably we can remove the viewmath.js/viewsource.css feature, since the
> view source command is already available in the contextual menu.

Yes, that makes sense.
Comment 4 Frédéric Wang (:fredw) 2011-10-13 05:16:07 PDT
Created attachment 566785 [details] [diff] [review]
Patch V2
Comment 5 Karl Tomlinson (:karlt) 2011-10-13 13:38:14 PDT
Comment on attachment 566785 [details] [diff] [review]
Patch V2

Looks good, thanks.
Comment 6 Frédéric Wang (:fredw) 2011-10-13 14:49:29 PDT
Created attachment 566945 [details] [diff] [review]
Patch V3
Comment 7 Frédéric Wang (:fredw) 2011-10-13 15:05:07 PDT
(In reply to Karl Tomlinson (:karlt) from comment #3)
> (In reply to Frédéric Wang [offline] from comment #1)
> > Probably we can remove the viewmath.js/viewsource.css feature, since the
> > view source command is already available in the contextual menu.
> 
> Yes, that makes sense.

entity.js seems to be only used in viewmath.js and can be removed too.
The <script/> inclusions should be removed from the *.xhtml files.
Comment 8 Frédéric Wang (:fredw) 2011-10-13 15:15:25 PDT
Created attachment 566954 [details] [diff] [review]
Patch V3 - part 2
Comment 9 Frédéric Wang (:fredw) 2011-10-13 15:33:30 PDT
Created attachment 566957 [details] [diff] [review]
Patch V3 - part 2

Note You need to log in before you can comment on or make changes to this bug.