bookmarks on personal toolbar don't do anything when clicked

VERIFIED FIXED

Status

SeaMonkey
Bookmarks & History
VERIFIED FIXED
17 years ago
7 years ago

People

(Reporter: A. Liu, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: critical for 0.8)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I updated my nightly build to 2001020512 from a nightly build from Feb. 2nd.
Under any of the included Mozilla themes, the bookmark list pops up, and I can
highlight whatever link I want, the list is dismissed, but nothing happens after
that.

Comment 1

17 years ago
I don't see this with trunk SEA build 2001020512, even after changing themes a
couple of times in a row.
-Are you saying that it works OK when you type in an URL manually, but not when
 you click a bookmark?
-What kind of connection are you on? 
-Are you using a proxy?
-Are you sure the online/offline icon bottom right was in online state at the
time you  tested this?

Comment 2

17 years ago
Confirming, build 2001020520 Win95, this only happens with bookmarks from the
personal toolbar, bookmarks accessed from the menu bar function OK. 

Comment 3

17 years ago
dupe of 67795 (which is a win2k bug).

Comment 4

17 years ago
Changing OS to all, confirming bug. Bookmarks on personal toolbar do nothing.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All

Comment 5

17 years ago
*** Bug 67795 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
*** Bug 67807 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
Modifying summary
Summary: bookmarks don't do anything when clicked → bookmarks on personal toolbar don't do anything when clicked

Comment 8

17 years ago
The problem can be solved by changing the first parameter of OpenBookmarkURL on
line 219 of /xpfe/browser/resources/content/navigator.xul to "event.target"
instead of just "event" (which results in a javascript error)
(Reporter)

Comment 9

17 years ago
Funny, my problem isn't with the personal toolbar (that works just fine). It
really is the bookmark menu that doesn't do anything for me. I was using
Junkbuster w/ Mozilla configured to use HTTP 1.0, but I disabled that, restarted
Mozilla, and still have the same problem. I'm using the 'net connection in my
dorm, typing URLs manually works, the online/offline icon tells me that I'm online.
(Reporter)

Comment 10

17 years ago
Ack! Sorry, brain ****. The summary is correct. I got the Bookmarks from the
personal toolbar mixed up with the personal toolbar itself (got too used to
using it and forgot about the existence of the Bookmarks menu at the top). 

Comment 11

17 years ago
Created attachment 24650 [details] [diff] [review]
event -> event.target

Comment 12

17 years ago
I had already made that patch and later found this bug report...

I don't know if the patch helps anything because the patch is so simple
but it's there. It does the same thing that Erdeg said.

Updated

17 years ago
Keywords: approval, patch, review

Comment 13

17 years ago
*** Bug 67964 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
r=jag.

Comment 15

17 years ago
really would be nice to see this in 0.8.  If we can get this in on the branch
that would be great.
Whiteboard: critical for 0.8
sr=blizzard

Comment 17

17 years ago
Checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 18

17 years ago
Okay, this works fine for me now. Now how about verifying it?

Comment 19

17 years ago
At your service ... VERIFIED Fixed with 2001020804 Moz builds.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Comment 20

12 years ago
I got the problem with personnal toolbar and bookmark menu on the latest 1.7.13 release candidate from 2006-04-05

It's obviously not fixed
You need to log in before you can comment on or make changes to this bug.