Email truncated for display

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
7 years ago
7 years ago

People

(Reporter: list0570, Unassigned)

Tracking

Other
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2012-01-21][needs protocol log])

(Reporter)

Description

7 years ago
I have the following all the time:

Someone sends an email with a few jpegs in it. TB shows the first few jpegs fine, then chops right across one image and fails to show any of the remaining ones. Viewing the raw data with ^U shows the whole email is chopped right in the middle of a line containing base64 encoded jpeg data. "Save as" for the chopped image saves a truncated file to disk.

Mail server is MS-Exchange 2003 through imap. The same thing happens with TB 3.1.11 on Linux, 3.1.11 on XP and 5.0.1 on XP. Turning off "show attachments inline" makes no difference, "save as" still gives a truncated file.

Googling gives nothing beyond people who forgot to turn on "show attachments inline".

Using KDE kmail as MUA (also IMAP) does not have this problem, so it's not directly server-related. I'm getting the distinct feeling TB just doesn't load the whole data from the server and just chops after 3886045 bytes through the middle of the 4th jpeg. There are no LAN network problems that I am aware of; in any case they would effect kmail the same. At other times TB can handle a 10MB attachment just fine (dog slow, but works).

This unfortunately makes it a bit impractical to use thunderbird here. :-(
I think we fixed a few issue related to exchange imap between 3.1 , and 5. Would it be possible for you to give Thunderbird 5 or 6 a try and see if your issue goes away ?

If it doesn't go away we'll probably need an imap log as described at https://wiki.mozilla.org/MailNews:Logging .
(Reporter)

Comment 2

7 years ago
The problem is still present with TB 6 on XP.
I'll try to get that imap log.

Updated

7 years ago
Whiteboard: [closeme 2012-01-21][needs protocol log]
RESOLVED INCOMPLETE due to lack of response to previous question. If you feel this change has been made in error, please respond to this bug with your reason why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

7 years ago
I agree with your "incomplete', but not with your "resolved". There is nothing resolved about this. Closing might make you feel better about the mozilla bug statistics but doesn't change the dry fact  that TB 9 on both Linux and Windows as client for SBS2003 exchange here are not fit for use.

The problem from my end is to find the time to verify that the very long log dump doesn't contain any data I'm not allowed to disclose.

I'm not complaining, just working within constraints. Someone else might beat me with the log. This issue is most certainly unresolved. (I can still confirm that e.g. kmail works fine.)
You need to log in before you can comment on or make changes to this bug.