Recently, Firefox sync cannot connect/has encountered problems, firefox says all sites are untrusted (including this one), and it keeps giving me the secure connection failed error.

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: chad001001, Unassigned)

Tracking

5 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Build ID: 20110707182747

Steps to reproduce:

Nothing, maybe started Firefox Sync...


Actual results:

3-fold:
For no reason, sync started encountering problems,
Firefox started saying many sites are untrusted including the Mozilla mainpage and Bugzilla,
and it started giving me Secure Connection failures.



Expected results:

Nothing at all, it should have been smooth browsing.
Synch doesn't work if the connection can't be encrypted.
The real issue is the https problem.

That are 3 reasons why this can happen:
a) someone attacks you (MITM attack)
b) your system date is wrong
c) your Firefox profile is broken (all root certificates are untrusted)

Please provide the exact error message that you get. We only need the "technical details" part from the error message.
Is your system date correct (month/year) ?
(Reporter)

Comment 2

7 years ago
My apologies, my date/time was indeed wrong. I never noticed that. That you very much for your time. I'm sorry for my blunder.
The certificates for the encryption have an expire date and if you set your date in the future, all certificates will be rejected because they seem to be expired.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID

Comment 4

6 years ago
when I press search I am getting this below error

DBD::mysql::db do failed: Lost connection to MySQL server during query [for Statement "UPDATE profile_search SET bug_list = ?, list_order = ? WHERE id = ?"] at Bugzilla/Object.pm line 391
	Bugzilla::Object::update('Bugzilla::Search::Recent=HASH(0x41f9e78)') called at Bugzilla/User.pm line 533
	Bugzilla::User::__ANON__() called at Bugzilla/Util.pm line 708
	Bugzilla::Util::on_main_db('CODE(0x4201ca8)') called at Bugzilla/User.pm line 555
	Bugzilla::User::save_last_search('Bugzilla::User=HASH(0x3ff3210)', 'HASH(0x3ff8148)') called at /var/www/html/bugzilla/buglist.cgi line 1104

For help, please send mail to the webmaster (root@localhost), giving this error message and the time and date of the error.

Comment 5

6 years ago
guruprasad: Totally unrelated to this *Firefox* bug report - your issue in comment 4 is handled in bug 763412. Please don't post random problems on random bug reports. Thanks!
You need to log in before you can comment on or make changes to this bug.