Closed Bug 677545 Opened 13 years ago Closed 1 year ago

[10.7] panels with titlebars not receiving mouse clicks

Categories

(Core :: Widget: Cocoa, defect)

x86
macOS
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: rcampbell, Unassigned)

References

(Blocks 1 open bug)

Details

In OS X 10.7 floating panels with titlebars (like the one in the Inspector's HTML panel) do not receive mouse clicks. Attempts to focus the panel result in the click event "falling through" the panel to whatever's positioned underneath it. Most confusing.
Have you made sure this doesn't happen on OS X 10.6 or 10.5?
Yes.
If I had 10.7 I'd break on PresShell::HandleEvent when the event is a mouse down and check that 'aView' is the view for the panel and check that 'frame' is the frame for the panel (if not then the GetPopupFrameForEventCoordinates call should make that so).
Severity: normal → S3

Unable to reproduce.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.