Investigate simplified Bouncer GeoIP update

RESOLVED FIXED

Status

Webtools
Bouncer
P1
critical
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: wenzel, Assigned: rik)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Bouncer currently runs on an old version of Maxmind's free GeoIP database. Bug 656366 asks for this DB to be updated, but the data coming from maxmind needs to be tweaked a little bit before it fits into bouncer's database.

Investigate what it takes to get an updated file from Maxmind into the bouncer DB. If it's really easy, we could run it on a cron job, but it's also fine if it's just a script that we can run by hand and point at a just-downloaded geoip file.
We also have some local modifications (eg bug 646076) which we'd like to preserve.
This is blocking a P1/critical, therefore it's a P1/critical.
Severity: normal → critical
Priority: -- → P1
Any update on this? We're getting more and more complaints about people being routed to incorrect regions because IP blocks have been reassigned.  IPv4 is volatile now because there's none left, so ISPs are selling unused netblocks to other ISPs a lot more frequently than they used to.
(Assignee)

Comment 4

6 years ago
So I added a Django command to update the database.

This relies on transactions being enabled on the server. From the dump of the database I have, it seems this table is using MyISAM so it should be migrated to InnoDB first.

https://github.com/Rik/tuxedo/commit/2d593361021b5be645d730759789443bc4efdd7c
(Assignee)

Comment 5

6 years ago
The work here is done.

https://github.com/fwenzel/tuxedo/commit/6c418838758541723ee69afc81c75279c55ba297

Closing to talk about running this script in bug 656366.
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Updated

6 years ago
Duplicate of this bug: 667985
You need to log in before you can comment on or make changes to this bug.