Last Comment Bug 677699 - TiledTextureImage::GetTileRect() computes the wrong offset
: TiledTextureImage::GetTileRect() computes the wrong offset
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla8
Assigned To: Benoit Girard (:BenWa)
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks: 675908
  Show dependency treegraph
 
Reported: 2011-08-09 14:39 PDT by Benoit Girard (:BenWa)
Modified: 2011-08-10 08:34 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
MoveTo -> MoveBy (927 bytes, patch)
2011-08-09 14:44 PDT, Benoit Girard (:BenWa)
florian.haenel: review+
Details | Diff | Splinter Review

Description Benoit Girard (:BenWa) 2011-08-09 14:39:43 PDT

    
Comment 1 Benoit Girard (:BenWa) 2011-08-09 14:44:58 PDT
Created attachment 551895 [details] [diff] [review]
MoveTo -> MoveBy

I don't think this we are hitting this error case but it could be in the future since it assumes that mImages[mCurrentImage]->GetTileRect()'s top left is 0,0 which is not guaranteed.
Comment 2 Florian Hänel [:heeen] 2011-08-09 15:37:41 PDT
Comment on attachment 551895 [details] [diff] [review]
MoveTo -> MoveBy

This is only a problem if you're nesting tiled textures, but you're right.

Note You need to log in before you can comment on or make changes to this bug.