Older versions are being updated during bulk compatibility bump when newer, public versions exist

RESOLVED FIXED in 6.2.4

Status

addons.mozilla.org Graveyard
Add-on Validation
P3
normal
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: krupa, Assigned: kumar)

Tracking

unspecified
6.2.4

Details

(URL)

(Reporter)

Description

7 years ago
Filing a bug for https://forums.mozilla.org/addons/viewtopic.php?f=20&t=3613

As per https://addons.mozilla.org/en-US/developers/feed/simple-timer-clocks, version 1.3.3 was updated in the last week's compatibility update for 7.*

However, this add-on already had a newer public version (1.3.4) at the time of bulk compatibility update. 

expected behavior:
Only latest versions are taken into account during bulk compatibility validation.

actual behavior:
An older version got updated when there was a newer public version of the add-on existed. See https://addons.mozilla.org/en-US/developers/addon/simple-timer-clocks/versions/
I think the check for already compatible public versions might be off by one.  That is, the filter should look for any public versions that are greater than or equal to target: 

addon.versions.filter(..., apps__max__version_int__gte=target_ver)

https://github.com/jbalogh/zamboni/blob/eca2855573792cd96dbb2044e50f93ef2afa9ddd/apps/zadmin/tasks.py#L135

I have not verified that this is the root cause but that is my best guess.
Priority: -- → P3
Target Milestone: --- → 6.2.1
Target Milestone: 6.2.1 → 6.2.2
Target Milestone: 6.2.2 → 6.2.3
Fixed: https://github.com/jbalogh/zamboni/commit/9225f06face0ceced3bb9360393f952eb954bebd

What happened before: For a run like 6.* -> 7.* An older version of an addon would get bumped even if it had a new version that supported *exactly* 7.*

What happens now: For the above scenario, the older version will not get bumped since it is not necessary.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: 6.2.3 → 6.2.4
Duplicate of this bug: 688314
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.