Investigate implications of processing all hang pairs on Socorro

RESOLVED WONTFIX

Status

Mozilla Metrics
Hadoop/HBase Operations
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: laura, Unassigned)

Tracking

unspecified
Unreviewed

Details

(Reporter)

Description

6 years ago
Daniel, please run some numbers on what would happen if we process both halves of all hang pairs.  I'm particularly interested in:
- capacity implications for HBase
- statistical bias introduced into aggregate reports on Socorro

Comment 1

6 years ago
The problem is that when we do that, the calculation of a total crash rate becomes messed up (or at least significantly more complicated), as then some part of the release reports would be throttled and some wouldn't be.
Also, hangs would probably always bubble up to the top of topcrasher lists on releases, as they'd have a factor 10 more reports as crashes with the same rate.
KaiRo: in the discussion that lead to this bug filing, we were unable to come up with an algorithm that didn't introduce some sort of bias.  The point of this bug is to figure out the impact of the bias to see if we can compensate for it.

Comment 3

6 years ago
Lars, sure, I was was just showing up two cases that cause problems here and that need to be looked at in the research being done for comment #0.

Comment 4

6 years ago
Closing out old issues. Not in current scope of work.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.