Permission for adding unsafe content

RESOLVED WONTFIX

Status

developer.mozilla.org
Editing
P2
normal
RESOLVED WONTFIX
7 years ago
5 years ago

People

(Reporter: openjck, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
In his user interview, Sheppy noted that MindTouch provides a user permission for adding unsafe content (in MindTouch, this means only unsafe HTML). Let's make sure Kuma has the same, and consider expanding the term "unsafe content" to represent things like unsafe JavaScript, etc.
(Reporter)

Updated

7 years ago
Blocks: 665745
(Reporter)

Updated

7 years ago
Depends on: 677814
(Reporter)

Updated

7 years ago
Duplicate of this bug: 665745
(Reporter)

Comment 2

7 years ago
As bug 665745 (now a dupe of this bug) mentioned, this permission *must* consider both HTML and JavaScript. That is, if a user has this permission, he must be able to upload unsafe JavaScript.

Updated

6 years ago
No longer blocks: 665745

Updated

6 years ago
Blocks: 757245
Priority: -- → P2
(Assignee)

Updated

6 years ago
Version: Kuma → unspecified
(Assignee)

Updated

6 years ago
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
(Reporter)

Updated

5 years ago
Component: Landing pages → Editing
Whiteboard: u=contributor c=users p=

Comment 3

5 years ago
Do we need this bug? Can we close?
Flags: needinfo?(eshepherd)
No longer relevant.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(eshepherd)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.