rebuild qt-sdk rpm to fix nagios disk warnings triggered by android-sdk-r13 rollout

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: bear, Assigned: bear)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

7 years ago
The rollout of sdk-r13 is causing most of the linux builders to get flagged by nagios' disk / check

The low-hanging-fruit solution is to move /tools/qt-4.6.3 to /builds and provide a symlink.

after talking to jhford in irc we will need to find the source tarball for this, tweak the path in the rpm spec and rebuild the rpm

also need to adjust the puppet manifest to install with a symlink
(Assignee)

Updated

7 years ago
Assignee: nobody → bear
(Assignee)

Updated

7 years ago
Summary: android-sdk-r13 rollout is triggering nagios / disk warnings → rebuild qt-sdk rpm to fix nagios disk warnings triggered by android-sdk-r13 rollout
(Assignee)

Comment 1

7 years ago
Created attachment 552460 [details] [diff] [review]
change qt-sdk rpm to point to /builds
Attachment #552460 - Flags: review?(jhford)
(Assignee)

Comment 2

7 years ago
Created attachment 552462 [details] [diff] [review]
change qt-sdk puppet to install to /builds and symlink /tools
Attachment #552462 - Flags: review?(jhford)
Comment on attachment 552462 [details] [diff] [review]
change qt-sdk puppet to install to /builds and symlink /tools

Review of attachment 552462 [details] [diff] [review]:
-----------------------------------------------------------------

::: os/centos.pp
@@ +194,5 @@
>                  require  => Package["fontconfig"];
>              }
> +            file {
> +                "/tools/qt-4.6.3":
> +                    ensure => "/builds/qt-4.6.3";

Cool.  Eventually, i'd be nice to have the mozconfigs point to the /builds/ location, but this is not at all blocking or important.
Attachment #552462 - Flags: review?(jhford) → review+
Comment on attachment 552460 [details] [diff] [review]
change qt-sdk rpm to point to /builds

Review of attachment 552460 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.  R+ dependent on a test build going green!
(Assignee)

Updated

7 years ago
Duplicate of this bug: 678473
Comment on attachment 552460 [details] [diff] [review]
change qt-sdk rpm to point to /builds

Bear has done two green builds, this should be good to deploy.  Thanks bear!
Attachment #552460 - Flags: review?(jhford) → review+
(Assignee)

Comment 7

7 years ago
Comment on attachment 552462 [details] [diff] [review]
change qt-sdk puppet to install to /builds and symlink /tools

committed changeset 433:67844e97c7e6
Attachment #552462 - Flags: checked-in+
(Assignee)

Comment 8

7 years ago
Comment on attachment 552460 [details] [diff] [review]
change qt-sdk rpm to point to /builds

committed changeset 33:6ec4e4245efb
Attachment #552460 - Flags: checked-in+
(Assignee)

Comment 9

7 years ago
pushed live to production - will close later today after things run clean
(Assignee)

Comment 10

7 years ago
marking as closed - no problems have shown up after a day of deploying
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.