XPCOM loading errors are hidden

RESOLVED INVALID

Status

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: davian818, Unassigned)

Tracking

SeaMonkey 2.2 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20110706 Firefox/5.0 SeaMonkey/2.2
Build ID: 20110706120824

Steps to reproduce:

I installed the mail client extension.


Actual results:

It behaved weird because was not able to load some XPCOM component, or whatever that ****.dll with NSModule export is called.


Expected results:

I should have received an error message that ****.dll, a component of Foo extension, failed to load because of <Reason>, and have been offered to disable that extension.

Comment 1

7 years ago
What mail client extension? and which version?

Make sure all the debugging preferences are turned on:
<https://developer.mozilla.org/en/setting_up_extension_development_environment#Development_preferences>
Also you should install Console² which is a replacement Error Console with more options.
<http://console2.mozdev.org/#C_latest>
(Reporter)

Comment 2

7 years ago
What for? I'm not a developer, I'm user and must get clear (human-readable and not in console) error messages instead of absolutly weird behaviour of extension which failed to load its component and didn't report it.

Comment 3

7 years ago
Please direct support questions to the author of the relevant extension. Thank you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.