no jquery action ellement on enabling css3 properties -moz-transform to ellement input[type=file]

VERIFIED FIXED in mozilla8

Status

()

Core
CSS Parsing and Computation
--
major
VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: adminnu, Assigned: mattwoodrow)

Tracking

({verified-aurora, verified-beta})

8 Branch
mozilla8
verified-aurora, verified-beta
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox8-)

Details

(Whiteboard: [qa!], URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110809 Firefox/8.0a1
Build ID: 20110809030751

Steps to reproduce:

Nightly http://aquantum-demo.appspot.com/file-upload button to add files ... stopped working in the assembly of 08/09/2010. On all other browsers, the problem is not observed. Perhaps the error is connected with a change in the assembly of 8.08-9.08.
(Reporter)

Updated

6 years ago
Severity: normal → major
OS: Windows 7 → All
Hardware: x86_64 → All

Comment 1

6 years ago
Last good nightly: 2011-08-03
First bad nightly: 2011-08-04

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3735fb1cd5ef&tochange=be4b064f1159

Local track down:

The first bad revision is:
changeset:   73735:08b756f93436
user:        Matt Woodrow <mwoodrow@mozilla.com>
date:        Wed Aug 03 15:04:21 2011 +1200
summary:     Bug 505115 - Part 8c - Use ray tracing to untransform 2d points on a 3d plane. r=roc

http://hg.mozilla.org/mozilla-central/rev/08b756f93436
Version: 8 Branch → Trunk
(Reporter)

Updated

6 years ago
Summary: jquery action error → no jquery action ellement
Version: Trunk → 8 Branch
(Reporter)

Comment 2

6 years ago
Yes, if you unplug. Fileupload-buttonbar. Ui-button input {-moz-transform: translate (-300px, 0pt) scale (4);
problem disappears.
(Reporter)

Updated

6 years ago
Blocks: 505115
(Reporter)

Updated

6 years ago
Summary: no jquery action ellement → no jquery action ellement on enabling css3 properties -moz-transform to ellement input[type=file]
(Reporter)

Updated

6 years ago
tracking-firefox8: --- → ?
Component: General → Style System (CSS)
Product: Firefox → Core
(Assignee)

Comment 3

6 years ago
Created attachment 553102 [details] [diff] [review]
Round untransformed rects outwards
Attachment #553102 - Flags: review?(roc)
(Assignee)

Updated

6 years ago
Assignee: nobody → matt.woodrow
(Assignee)

Updated

6 years ago
Duplicate of this bug: 678151
Attachment #553102 - Flags: review?(roc) → review+
test?
(Assignee)

Comment 6

6 years ago
Created attachment 553127 [details] [diff] [review]
Round untransformed rects outwards v2

Added test
Attachment #553102 - Attachment is obsolete: true
Attachment #553127 - Flags: review?(roc)
Comment on attachment 553127 [details] [diff] [review]
Round untransformed rects outwards v2

Review of attachment 553127 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/base/tests/test_bug677878.html
@@ +41,5 @@
> +  setTimeout(doClick, 300);
> +}
> +
> +function testFinish(event){
> +  ok(1, "We can still interact with the item after it is transformed");

ok(true,
Attachment #553127 - Flags: review?(roc) → review+
http://hg.mozilla.org/mozilla-central/rev/91d90510179c
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla8
(Reporter)

Comment 9

6 years ago
Thanks problem solved.

Comment 10

6 years ago
Matt or Roc, is this needed on Aurora? Not sure about the tracking request here.
Doesn't Aurora already have this fix? This was landed for Mozilla8.

Comment 12

6 years ago
---------------------------------[ Triage Comment ]---------------------------------

This looks like it already landed for Firefox 8 when it was on mozilla-central so we don't need to track. Adding the dev-doc-needed keyword in case this fix should be called out for web developers.
tracking-firefox8: ? → -
Keywords: dev-doc-needed
What is this change exactly? I'm unsure from reading this. Is it that transforms were breaking delivery of some event?
(Assignee)

Comment 14

6 years ago
Yes, the 3D transforms patches included changes to some of the event handling code. This was a regression where click handling within a transformed object was broken.
(Reporter)

Comment 15

6 years ago
I recently found another problem. Just configured text will describe it.
Removing doc needed flag, since 3D transforms aren't documented yet anyway. That will be handled under another bug.
Keywords: dev-doc-needed

Comment 17

6 years ago
/tests/layout/base/tests/test_bug677878.html is passing on all OSs:
Firefox 9.0 (Beta 2):
https://tbpl.mozilla.org/php/getParsedLog.php?id=7438809&full=1&branch=mozilla-beta
https://tbpl.mozilla.org/php/getParsedLog.php?id=7438682&full=1&branch=mozilla-beta
https://tbpl.mozilla.org/php/getParsedLog.php?id=7444774&full=1&branch=mozilla-beta
https://tbpl.mozilla.org/php/getParsedLog.php?id=7444772&full=1&branch=mozilla-beta

Firefox 10.0 (Aurora):
https://tbpl.mozilla.org/php/getParsedLog.php?id=7442540&full=1&branch=mozilla-aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=7440940&full=1&branch=mozilla-aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=7443889&full=1&branch=mozilla-aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=7443791&full=1&branch=mozilla-aurora

Firefox 11.0 (Nightly):
https://tbpl.mozilla.org/php/getParsedLog.php?id=7407009&full=1&branch=services-central
https://tbpl.mozilla.org/php/getParsedLog.php?id=7407021&full=1&branch=services-central
https://tbpl.mozilla.org/php/getParsedLog.php?id=7408736&full=1&branch=services-central
https://tbpl.mozilla.org/php/getParsedLog.php?id=7406146&full=1&branch=services-central
Status: RESOLVED → VERIFIED
Keywords: verified-aurora, verified-beta
Whiteboard: [qa!]
You need to log in before you can comment on or make changes to this bug.