Last Comment Bug 677880 - get rid of nsIScriptableInterfaces
: get rid of nsIScriptableInterfaces
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla9
Assigned To: arno renevier
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-10 05:37 PDT by arno renevier
Modified: 2011-08-18 03:54 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
rename nsIScriptableInterfaces and nsIScriptableInterfacesByID (19.70 KB, patch)
2011-08-10 05:39 PDT, arno renevier
mrbkap: review+
Details | Diff | Splinter Review

Description arno renevier 2011-08-10 05:37:52 PDT
Hi,
Currently, Components.interfaces implements nsIScriptableInterfaces and can be invoked with contract id "@mozilla.org/scriptableinterfaces;1"
That interface allow to define an non default nsIInterfaceInfoManager for Components.interfaces

See bug #123770
It looks unused today. So maybe, nsIScriptableInterfaces can be simplified back to nsIXPCComponents_Interfaces.
That would be more consistent with other Components property.
Comment 1 arno renevier 2011-08-10 05:39:08 PDT
Created attachment 552055 [details] [diff] [review]
rename nsIScriptableInterfaces and nsIScriptableInterfacesByID

patch proposal:
remove setManager, rename nsIScriptableInterfaces to 
nsIXPCComponents_Interfaces, define it in xpccomponents.idl, and make Components.interfaces not an xpcom object anymore
Comment 2 arno renevier 2011-08-10 05:41:30 PDT
I've tested this patch already. It looks like it breaks nothing:
http://tbpl.mozilla.org/?tree=Try&rev=3adb6f0528ac
Comment 3 Blake Kaplan (:mrbkap) 2011-08-12 15:25:25 PDT
Comment on attachment 552055 [details] [diff] [review]
rename nsIScriptableInterfaces and nsIScriptableInterfacesByID

Yes, please.
Comment 5 Marco Bonardo [::mak] 2011-08-18 03:54:37 PDT
http://hg.mozilla.org/mozilla-central/rev/b23c1a9de86c

Note You need to log in before you can comment on or make changes to this bug.