Attachments corrupted when 'Save As' or new 'Save All' button used

RESOLVED INVALID

Status

P1
major
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: tanstaafl, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 552056 [details]
Forward of moderated message.eml

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

We deal with a lot of attachments.

Since we started upgrading to Thunderbird 5, we have had a LOT of problems with attachments corrupted when saved. This does not happen with all attachments, but it happens a lot.

The only really reliable way I can reproduce this is with our mailman lists, although it *is* happening with non-list messages (from outside our office) as well, so this is NOT limited to only messages that have gone through mailman...

If I send an attachment that is bigger than the allowed size, I get an email (as the admin) that the message is being held up. I log into as admin, and 'discard' the message, but send a copy to the admin (me), so I can strip off the attachment and put it in a shared location for everyone, then I resend the message to the list with a link to the file...

I've been doing this for many years, and the *only* thing that has changed is Thunderbird.

1. Receive email with an attachment

2 [review]. Open attachment by dbl-clicking - it opens just fine.

3. Save As from opened attachment - saved copy opens just fine.

4. Instead of dbl-clicking the attachment, right-click on it and click 'Save As' - the saved document is corrupted and will not open

5. Same corruption happens if the new 'Save All' button on the right is used.

This is an EXTREMELY serious bug, one which will result in my boss TERMINATING our use of Thunderbird (we've been using it since about version 0.8) for all 50+ of our users, if this cannot be squashed very quickly.

Please do not hesitate to contact me for more samples of problem messages.


Actual results:

Attachment is corrupted...


Expected results:

attachment should not be corrupted
(Reporter)

Comment 1

7 years ago
Oh - if the attachment is a spreadsheet, it attempts to open with the converter dialog, and I can see in the preview garbage from the email headers...
(Reporter)

Updated

7 years ago
Severity: normal → blocker
Priority: -- → P1

Comment 2

7 years ago
Saving either attachment in the .eml from comment 0 works fine for me in 5.0.
(Reporter)

Comment 3

7 years ago
Ok, after downloading the .eml file I uploaded, it did for me too...

But it still does what I described above when 'Save As' or 'Save All' is used from the ORIGINAL email in my mailbox, so something about Saving the .eml file must fix it.

And for the record, I did try this while in Safe Mode, and it still happens.

There is a very serious bug here, now we just have to figure out how some of you can reproduce it...

Woudl someone be available for me to try forwarding the email to, and see if you can reproduce it that way?

Comment 4

7 years ago
(In reply to Charles from comment #3)
> Woudl someone be available for me to try forwarding the email to, and see if
> you can reproduce it that way?

Go for it. A regression range would be particularly helpful here... (Which I'd rather not do right now, since I've already got another bug that I need to find a regression range for.)
(Reporter)

Comment 5

7 years ago
Ok, this ticks me off...

Before forwarding to you, I forwarded it to one of my personal accounts, and it worked fine.

So, I decided to see what might be different about the two folder...

My other accounts Inbox was set to offline use...

The Inbox for the problem account was not. I enabled it, clicked 'download no' downloaded all of the messages, and now it works...

What settings could possibly be affecting this? I have the cache set to 0, but am not sure what other settings I may have changed manually while troubleshooting the other attachment problems TB has been plagued with in t he past...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

7 years ago
Setting the folder to offline use worked for the messages that were already in the folder, but new messages still exhibit this problem.

I need some help here. Everyone who has upgraded to TB5 is experiencing this problem.
(Reporter)

Updated

7 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 7

7 years ago
Here are some settings that I have in our user.js file - anyone see anything here that could cause problems with attachments and/or inline images?

// Add List-ID Header
user_pref("mailnews.customHeaders", "List-ID");

// Mail Reply header
user_pref("mailnews.reply_header_type", 2);

// Mail Interface preferences
user_pref("browser.preferences.instantApply", true); // make window non-modal

// Fix performance bugs with TB5 - see http://kb.mozillazine.org/Thunderbird_5.0_-_New_Features_and_Changes#Font_rendering_and_performance_issues
user_pref("gfx.direct2d.disabled", true);
user_pref("layers.acceleration.disabled", true);

user_pref("mail.addr_book.quicksearchquery.format", "?(or(Company,c,@V)(PrimaryEmail,c,@V)(DisplayName,c,@V)(FirstName,c,@V)(LastName,c,@V))");
user_pref("mail.folder.views.version", 3); // show normal account/folders view
user_pref("mail.root.imap-rel", "[ProfD]../../../../Local Settings/Thunderbird/ImapMail"); // set ImapMail root to Local Settings
user_pref("mail.root.imap", "[ProfD]../../../../Local Settings/Thunderbird/ImapMail"); // set ImapMail root to Local Settings
user_pref("mail.server.default.archive_granularity", 0); // disable the 'year' folders in the designated Archive folder

user_pref("mail.tabs.autoHide", true); // hide tab bar if only one tab is open
user_pref("mail.warn_on_send_accel_key", false); // don't prompt on Ctrl-Enter

// Activate 'Sync-On-Demand' mode
user_pref("browser.cache.disk.enable", false);
user_pref("browser.cache.memory.enable", false);
user_pref("browser.cache.memory.capacity", 0);
user_pref("mail.server.default.autosync_offline_stores", false);

// Completely disable network prefetching
user_pref("network.prefetch-next", false);
user_pref("network.dns.disablePrefetch", true);
user_pref("network.dns.disableIPv6", true);
user_pref("network.dns.disablePrefetchFromHTTPS", true);

// fix attachment bugs
user_pref("mail.imap.fetch_by_chunks", false);
user_pref("mail.server.default.fetch_by_chunks", false);
user_pref("mail.imap.mime_parts_on_demand", false);
user_pref("mail.server.default.parts_on_demand", false);

// Attachment prefs for OpenAttachmentByExtension extension
user_pref("openattachment.extension.dat", "K:\administrative\apps\wmo\wmopener.exe");

// Miscellaneous preferences
user_pref("calendar.google.enableEmailInvitations", true); //self-explanatory - enables email invites for google calendars
user_pref("mail.default_html_action", 3); //send messages in both plaintext and html
//user_pref("mail.mdn.report.enabled", false); //disable return receipts (mine only)
user_pref("mail.SpellCheckBeforeSend", true);
user_pref("mail.showCondensedAddresses", false); //disable condensed addresses in message headers
user_pref("mailnews.database.global.indexer.enabled", false); //disable Global Search and Indexer
(Reporter)

Comment 8

7 years ago
Anyone? This is driving us crazy...
(In reply to Charles from comment #5)
> So, I decided to see what might be different about the two folder...
> 
> My other accounts Inbox was set to offline use...
> 
> The Inbox for the problem account was not. I enabled it, clicked 'download
> no' downloaded all of the messages, and now it works...

So, if I'm reading this correctly, the problem occurs only on an IMAP Inbox folder which does not store offline storage?

If so, I can guess that the problem might be caused by the IMAP server returning bad data for the attachments. An IMAP log that encompasses the time when this occurs would help debug:
<https://wiki.mozilla.org/MailNews:Logging>.

[Side note: this does not meet the criteria for a blocker]
Severity: blocker → major

Comment 10

7 years ago
This happens to me as well and I use POP, not IMAP. I do not have any offline settings, I presume these only apply to IMAP accounts? As per the original description, the attachments are fine and can be opened directly, it is just using Save As that corrupts them.
(Reporter)

Comment 11

7 years ago
Discovered this was caused by some of those manual changes I had made to the user.js file, namely these:

// Activate 'Sync-On-Demand' mode
user_pref("browser.cache.disk.enable", false);
user_pref("browser.cache.memory.enable", false);
user_pref("browser.cache.memory.capacity", 0);
user_pref("mail.server.default.autosync_offline_stores", false);

// fix attachment bugs
user_pref("mail.imap.fetch_by_chunks", false);
user_pref("mail.server.default.fetch_by_chunks", false);
user_pref("mail.imap.mime_parts_on_demand", false);
user_pref("mail.server.default.parts_on_demand", false);

trying to solve some other problems... reset these changes to their defaults, and problem is gone...

Closing as INVALID, and sorry for the noise...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.