Last Comment Bug 677922 - Package pyxpidl in the SDK
: Package pyxpidl in the SDK
Status: RESOLVED FIXED
fixed-in-bs
: dev-doc-complete
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
:
Mentors:
Depends on:
Blocks: 578790 660861
  Show dependency treegraph
 
Reported: 2011-08-10 08:46 PDT by Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
Modified: 2011-12-12 06:22 PST (History)
3 users (show)
khuey: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (3.80 KB, patch)
2011-09-07 08:26 PDT, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
benjamin: review+
Details | Diff | Splinter Review

Description Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-08-10 08:46:09 PDT
I assume if we dump all the scripts in the same directory things should just work without pythonpath magic?
Comment 1 Benjamin Smedberg [:bsmedberg] 2011-08-10 09:10:12 PDT
xpt.py will be part of this, right? Several people have asked for that since we're not packaging the xpt_link binary any more.
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-08-10 09:11:50 PDT
Yes, without it the typelib generator would fail.

I think we should probably throw in some wrappers that reimplement the old options behavior for xpidl/xpt_link etc.
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-09-07 08:26:02 PDT
Created attachment 558820 [details] [diff] [review]
Patch

I decided not to throw in wrappers for the old arguments.
Comment 4 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-09-07 12:34:15 PDT
http://hg.mozilla.org/projects/build-system/rev/38cdd84efa53
Comment 5 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-09-15 19:19:22 PDT
https://hg.mozilla.org/mozilla-central/rev/38cdd84efa53
Comment 6 Eric Shepherd [:sheppy] 2011-11-15 11:24:11 PST
What needs to be documented here, exactly? The build system is scary black magic to me in many respects. :)
Comment 7 Eric Shepherd [:sheppy] 2011-12-12 06:22:10 PST
Documented:

https://developer.mozilla.org/en/XPIDL/pyxpidl

Documentation revised:

https://developer.mozilla.org/en/XPIDL
https://developer.mozilla.org/en/XPIDL/xpidl

Mentioned on Firefox 9 for developers.

Note You need to log in before you can comment on or make changes to this bug.