After saving changes on a page the content is not updated for logged in users

RESOLVED INVALID

Status

Websites
wiki.mozilla.org
--
major
RESOLVED INVALID
7 years ago
3 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
Today I have worked on the page referenced in the URL section of this bug. While updating the template and the content of the page itself, the page got into a state which didn't show up all the edits I have made. Whether if I reloaded the page, cleared the cache and reloaded - nothing changed. Starting Firefox with another profile did the trick and the new content showed up. In the old profile the problem was still existent.

As it turned out the problem was that it only affects users who are logged into the wiki. If you are not logged in the issue will never be seen. So why do we not serve the updated content to logged in users in some situations? Why do we explicitly have to call purge on the page to get it refreshed?

This happens across different browsers, so it's clearly a fault on the server side.
If this is another Semantic Mediawiki page, that would explain a lot of things :|
It is a Semantic Mediawiki query page, but I've never seen it get completely locked up like this before.  Nothing at all was working to update the page except for logging out.  

Henrik mentioned that they had seen problems with non-SMW pages not updating properly as well.
(Reporter)

Comment 3

7 years ago
Correct. That was for pages like:
https://wiki.mozilla.org/QA/Automation_Services/Meetings/110810

We simply updated content by hand and it didn't appear until you have hit Cmd+Shift+R to force the reload.

But this time it was absolutely worse. We should really get this fixed because its frustrating for anyone who edits wiki pages and especially SMW ones.
MediaWiki has its own caching system, particularly when it comes to templates. Have you tried adding 'action=purge' to the end of the URL?

Something like this:
http://wiki.mozilla.org/index.php?title=QA/Automation_Services/Meetings/110810&action=purge
(Reporter)

Comment 5

7 years ago
See my comment 0. After we used purge it was working for logged in users. But that shouldn't be a requirement when it comes to differences between logged-in users and visitors.
Unable to verify, so closing. 

It sounds like this might be intended behavior due to caching, and that if the isue still exists, we can address UX concerns as we develop the new theme.

Please re-open with additional information (including theme used and screen capture) if you're still experiencing the issue.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 7

4 years ago
(In reply to Christie Koehler [:ckoehler] from comment #6)
> Unable to verify, so closing. 

Wontfixing a bug because you can't reproduce it is not the right action here. But for sure we can close as incomplete and reopen if I or someone else sees this again.
Resolution: WONTFIX → INCOMPLETE
(Reporter)

Comment 8

4 years ago
I had the same problem again today when I was updating the table class for our team members here:
https://wiki.mozilla.org/QA/Automation/Team

All was shown correctly on that page, but when I open the page (https://wiki.mozilla.org/QA/Automation#Team) which includes this subpage, the updated style was not visible. I had to log out first. A shift+reload even didn't help!
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
(In reply to Henrik Skupin (:whimboo) from comment #8)
> All was shown correctly on that page, but when I open the page
> (https://wiki.mozilla.org/QA/Automation#Team) which includes this subpage,
> the updated style was not visible. I had to log out first. A shift+reload
> even didn't help!

Did you try purging the page (as mentioned in earlier comments)? 

If you're using the default theme (Vector) you can access this via the menu:
https://wiki.mozilla.org/images/d/d0/MozillaWiki_-_Purge_Page.png
As mentioned before, this an artifact of caching in MediaWiki, and the solution is to purge the page.

I'm going to go so far as to say that this is not a bug.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.