Last Comment Bug 678039 - [Mac] White line appears on the very top of browser window
: [Mac] White line appears on the very top of browser window
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Cocoa (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla8
Assigned To: Markus Stange [:mstange]
:
Mentors:
Depends on:
Blocks: 668195
  Show dependency treegraph
 
Reported: 2011-08-10 13:38 PDT by d.a.
Modified: 2012-11-07 03:08 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot of the line (5.29 KB, image/png)
2011-08-10 13:38 PDT, d.a.
no flags Details
v1 (1.59 KB, patch)
2011-08-10 13:55 PDT, Markus Stange [:mstange]
jaas: review+
Details | Diff | Review

Description d.a. 2011-08-10 13:38:40 PDT
Created attachment 552203 [details]
Screenshot of the line

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0a1) Gecko/20110810 Firefox/8.0a1
Build ID: 20110810030738

Steps to reproduce:

With the latest nightly running Snow Leopard a white line appears on top of the browser window (hex color: f7f7f7), and did not exist before. The line is quite visible and is somewhat distracting. See the attached screenshot.

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=87e3ea12ed5d&tochange=04dfb49d3a3d

Likely caused by  bug 668195 or bug 667476.
Comment 1 Markus Stange [:mstange] 2011-08-10 13:55:18 PDT
Created attachment 552206 [details] [diff] [review]
v1

Limit the overdraw workaround to Lion where the color fits. The bug only happens on Lion.
Comment 2 Bram Pitoyo [:bram] 2011-08-11 03:14:48 PDT
I can confirm that this bug is also present in Snow Leopard and Leopard.

The hex color value we should be using is #e2e2e2.
Comment 3 Markus Stange [:mstange] 2011-08-12 13:42:04 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/44570a422531
Comment 4 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-08-14 05:01:48 PDT
http://hg.mozilla.org/mozilla-central/rev/44570a422531

Note You need to log in before you can comment on or make changes to this bug.